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Pup.exe does not add Web services when you run the tool at a command prompt in Commerce Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft Commerce Server 2009 Standard Edition.
  • You create a Commerce Server site that contains a Commerce Server application.
  • You try to add some Web services to this site by using the Commerce Server Site Packager (Pup.exe) tool at a command prompt. The Web services are packaged in a .pup file.
In this scenario, the Web services are not added to the site. Additionally, an error message that resembles the following is logged in the Pup.log file:

Commerce Server Standard Edition supports a maximum of 1 web-application per site (not including the webservices). Please try selecting a different set of applications and retry.

Note
This issue also occurs when you install Commerce Server 2009 Enterprise Edition on a computer that has Microsoft Commerce Server 2007 Standard Edition installed.

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Cause

This issue occurs because the number of Web services for the site is incorrectly limited when you run Pup.exe at the command prompt.

Note Commerce Server 2009 Standard Edition has a limit of only one Commerce Server application for each Commerce Server site.

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Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have Microsoft Commerce Server 2009 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Cs2009hotfixhelper.exe6.0.4171.3113,08020-Oct-201007:59x86
Pup.exe6.0.4171.31965,46420-Oct-201008:00x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this issue, run Commerce Server Site Packager (Pup.exe) User Interface (UI) to unpack the .pup file.

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References

For more information about how to run site packager from the command line, visit the following Microsoft website:For more information about Commerce Server 2009 editions, visit the following Microsoft website:

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Keywords: kbexpertiseadvanced, kbsurveynew, kbhotfixdev, kbautohotfix, kbhotfixserver, kbqfe, kb, kbfix

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Article Info
Article ID : 2448145
Revision : 2
Created on : 9/19/2018
Published on : 9/19/2018
Exists online : False
Views : 311