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An AD FS-enabled web application that is published for AD FS authentication on a Windows Server 2008 R2-based computer cannot decode session cookies that are received out of order


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Active Directory Federation Services (AD FS) 2.0 on a computer that is running Windows Server 2008 R2.
  • You publish a web application for AD FS authentication on the computer.
In this scenario, the AD FS-enabled web application cannot decode session cookies that are received out of order. Additionally, some clients and some browsers may receive a "500" error when they attempt to connect to the AD FS-enabled web application.

Notes
  • Some web browsers may not return some cookies in the same order when the validation of the cookies is broken.
  • Not all "500" errors are caused by this issue.

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Cause

This issue occurs because the AD FS component expects the cookies to have a sequence like "Name=value;Name0=value0;". The existing mechanism to process the cookies is incorrect when the order of the cookies is not the same.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running the following operating system:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)

Additionally, you must have Active Directory Federation Services (AD FS) 2.0 installed.

Registry information

You do not have to change the registry to use the hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, very important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Adfs_schema.xmlNot applicable4,61610-Jun-200920:49Not applicable
Ifsext.dll6.1.7600.20861106,49618-Dec-201006:06x64
Adfs_schema.xmlNot applicable4,61605-Nov-201002:05Not applicable
Ifsext.dll6.1.7601.21624106,49618-Dec-201008:51x64
Ifsfilt.dll6.1.7601.1751424,57620-Nov-201013:26x64
Ifssvc.exe6.1.7601.1751462,46420-Nov-201013:24x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about AD FS, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684

Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_468e836188bdcf213f7f6efd4ec99ec2_31bf3856ad364e35_6.1.7601.21624_none_eee94c2f8c9acccd.manifest
File versionNot applicable
File size1,062
Date (UTC)20-Dec-2010
Time (UTC)23:27
PlatformNot applicable
File nameAmd64_9e0b2b535e1036d4e9e3c7bada93d89a_31bf3856ad364e35_6.1.7600.20861_none_8061421d14588f84.manifest
File versionNot applicable
File size1,062
Date (UTC)20-Dec-2010
Time (UTC)23:27
PlatformNot applicable
File nameAmd64_microsoft-windows-adfs-webagenttoken_31bf3856ad364e35_6.1.7600.20861_none_1971df89bbfd1d1c.manifest
File versionNot applicable
File size10,412
Date (UTC)20-Dec-2010
Time (UTC)23:28
PlatformNot applicable
File nameAmd64_microsoft-windows-adfs-webagenttoken_31bf3856ad364e35_6.1.7601.21624_none_1b867d1db9006549.manifest
File versionNot applicable
File size10,412
Date (UTC)20-Dec-2010
Time (UTC)23:28
PlatformNot applicable
File nameWow64_microsoft-windows-adfs-webagenttoken_31bf3856ad364e35_6.1.7600.20861_none_23c689dbf05ddf17.manifest
File versionNot applicable
File size3,275
Date (UTC)18-Dec-2010
Time (UTC)05:49
PlatformNot applicable
File nameWow64_microsoft-windows-adfs-webagenttoken_31bf3856ad364e35_6.1.7601.21624_none_25db276fed612744.manifest
File versionNot applicable
File size3,275
Date (UTC)18-Dec-2010
Time (UTC)08:22
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kb

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Article Info
Article ID : 2445324
Revision : 1
Created on : 1/7/2017
Published on : 6/21/2014
Exists online : False
Views : 231