Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Visual Studio 2010 command prompt stops responding when you build a setup project by using Devenv.com


View products that this article applies to.

Symptoms

When you try to build a Microsoft Visual Studio 2010 setup project by using Devenv.com in the Visual Studio 2010 command prompt, the command prompt may stop responding. In this situation, you do not receive error messages, and the setup package of the project is not generated.

↑ Back to the top


Cause

This problem occurs because of a deadlock that is caused by a code defect in Devenv.com.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


Note You can also download this hotfix from the following Microsoft website:

Prerequisites

To apply this hotfix, you must have Visual Studio 2010 installed.

Restart requirement


You have to restart the computer after you apply this hotfix if the affected files are being used.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported versions of Visual Studio 2010
File nameFile versionFile sizeDateTimePlatform
Microsoft.visualstudio.commonide.dll10.0.30319.401478,08009-Dec-201023:35x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbhotfixdev, kbqfe, kbfix, kbhotfixserver, kbexpertiseadvanced, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2444922
Revision : 1
Created on : 1/7/2017
Published on : 1/12/2011
Exists online : False
Views : 209