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You cannot access a host that is hosting the IPv4 file share by using SMB v1 from a Windows 7-based or Windows Server 2008 R2-based DirectAccess client


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2 or Windows 7.
  • Condition A, the "former connection": You connect a file share on the computer by using the Server Message Block (SMB) protocol or DirectAccess over a network address translation (NAT) device.
  • Condition B, the "latter connection": Another client computer tries to connect the same file share by using the SMB protocol or the DirectAccess protocol over the same NAT device.
In this scenario, the former connection (Condition A) is disconnected when the latter connection (Condition B) is established.

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Cause

When the latter connection (Condition B) is established to the file share server, the server compares the client IPv4 address of this connection with the former connection (Condition A). If these two connections use the same client IPv4 address, then the server disconnects the former connection (Condition A). In this case, NAT device acts as a proxy for the SMB protocol or for DirectAccess and uses the same IPv4 address from the two client connections. Therefore, the former connection (Condition A) is disconnected when the latter connection (Condition B) is established from the same NAT device.

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Resolution

Hotfix information

A supported feature that modifies the default behavior of the product is available from Microsoft. However, this feature is intended to modify only the behavior that this article describes. Apply this feature only to systems that specifically require it. This feature might receive additional testing. Therefore, if the system is not severely affected by the lack of this feature, we recommend that you wait for the next software update that contains this feature.

If the feature is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the feature.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific feature. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the feature is available. If you do not see your language, it is because the feature is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To use the hotfix in this package, you must create a registry subkey. To do this, follow these steps:
  1. Click Start, type regedit in the Search programs and files box, and then press ENTER.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SMB1NATCompatibilityLevel, and then press ENTER.
  5. Right-click SMB1NATCompatibilityLevel, and then click Modify.
  6. In the Value data box, type one of the following values, and then click OK:
    • 0 = default behavior
    • 1 = TCP/445 over IPv6 only (Use this value for DirectAccess situations)
    • 2 = Always (Subject to change in future updates)
    • 3 = Always (TCP/445 over IPv4 or IPv6. Use this value for NAT situations)
  7. Exit Registry Editor.
In step 6, when you set the value to 1, 2, or 3, and the condition is met, the VcNumber is set to a nonzero value.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.20841221,69624-Nov-201003:23x86
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.20841286,72024-Nov-201003:53x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7600.20841673,79224-Nov-201003:01IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about DirectAccess, visit the following Microsoft TechNet website: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301673 You cannot make more than one client connection over a NAT device
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2 and for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,880
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable
File nameX86_e63206713b85ebd2ebc0165de01daa49_31bf3856ad364e35_6.1.7600.20841_none_608e66be455b4562.manifest
File versionNot applicable
File size701
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable
File nameX86_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.20841_none_892bc497c5c3023c.manifest
File versionNot applicable
File size3,962
Date (UTC)24-Nov-2010
Time (UTC)06:08
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
File nameAmd64_a8230cfdb0f118a25960fee0d4ceea1a_31bf3856ad364e35_6.1.7600.20841_none_81f965d5de7a9846.manifest
File versionNot applicable
File size705
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable
File nameAmd64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.20841_none_e54a601b7e207372.manifest
File versionNot applicable
File size3,966
Date (UTC)24-Nov-2010
Time (UTC)07:04
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,114
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_ff76076aa23d4998a96851703adeddd5_31bf3856ad364e35_6.1.7600.20841_none_e5ce44e9e6a54cb0.manifest
File versionNot applicable
File size703
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable
File nameIa64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7600.20841_none_892d688dc5c10b38.manifest
File versionNot applicable
File size3,964
Date (UTC)24-Nov-2010
Time (UTC)06:59
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,690
Date (UTC)24-Nov-2010
Time (UTC)08:43
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2444558
Revision : 1
Created on : 1/7/2017
Published on : 12/28/2010
Exists online : False
Views : 258