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FIX: An application that is based on the .NET Framework 4.0 does not retrieve custom properties of an application from a Single Sign-On (SSO) database on a computer that is running Enterprise Single Sign-On v4.0


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Microsoft .NET Framework 4.0 on the computer.
  • You use a Microsoft�Enterprise Single Sign-On (SSO) version 4.0 database as a configuration store.

    For example, you create a�Single Sign-On application that is named App1. You also create two custom properties that are named Prop1 and Prop2 for application App1. Then, you save values for Prop1 and Prop2 into the SSO database.

  • You develop an application that is based on the Microsoft .NET Framework 4.0 that references the Microsoft.BizTalk.Interop.SSOClient.DLL assembly to retrieve the two property values for application App1 from the SSO database.�

In this scenario, the application may not successfully retrieve the custom property values.

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Cause

The issue occurs because the Microsoft.BizTalk.Interop.SSOClient.DLL assembly does not work well with the .NET Framework 4.0.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Enterprise Single Sign-On v4.0 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For 32-bit Microsoft Enterprise Single Sign-On v4.0
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.interop.ssoclient.dll6.0.301.218,31213-Oct-201013:38x86
Microsoft.enterprisesinglesignon.interop.dll6.0.301.234,70413-Oct-201013:38x86
For 64-bit Microsoft Enterprise Single Sign-On v4.0
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.interop.ssoclient.dll6.0.301.218,31213-Oct-201013:46x86
Microsoft.enterprisesinglesignon.interop.dll6.0.301.234,70413-Oct-201013:46x86




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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to use SSO as a Configuration Store, visit the following Microsoft Developers Network (MSDN) website:If you encounter the 0x80131700 error code when you start or configure the Enterprise Single Sign-On Service after you install the .NET Framework 4.0, apply the hotfix that is described in article 2252691. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2252691 FIX: 0x80131700 error code when starting or configuring the Enterprise Single Sign-On Service
For more information about Enterprise Single Sign-On, visit the following Microsoft Developer Network (MSDN) website:For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk Server hotfixes

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Keywords: kbbug, kbqfe, kbHotfixServer, kbfix, kbbiztalk2009presp1fix, kbexpertiseinter, kbprb, kbsurveynew, kbautohotfix, KB2427229

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Article Info
Article ID : 2427229
Revision : 1
Created on : 11/12/2010
Published on : 11/12/2010
Exists online : False
Views : 503