Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

SIFT Tables left over after converting a database to use Indexed Views in Microsoft Dynamics NAV


View products that this article applies to.

Symptoms

In some cases, after upgrading a NAV database from Version 5 or earlier to Version 5 SP1 or later, the conversion may leave unnecessary tables named CRONUS$37$4 or similar in the database. These tables do not cause any problems, but they can contain a lot of data, and they are not needed.

↑ Back to the top


Cause

Before version 5 SP1, NAV maintained SIFT totals in SIFT tables. Since version 5 SP1, this has been changed to maintain the totals in Indexed Views. So conversion of a database from a previous version to version 5 SP1 or later, will remove the old SIFT tables and generate new Indexed views instead. Generation of the new Indexed views happens without problems, but in some cases, not all SIFT tables will get deleted. So in this case, the database will still have tables with a naming convention like this:

[CompanyName]$TableName$IndexNumber

These tables can be safely deleted from the SQL Server

↑ Back to the top


Keywords: kbmbsmigrate, kbmbspartner, vkball, kb

↑ Back to the top

Article Info
Article ID : 2425768
Revision : 2
Created on : 1/27/2017
Published on : 1/27/2017
Exists online : False
Views : 288