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FIX: Error message when you use Microsoft SharePoint Commerce Services Configuration Wizard to create a site: "The job creating the profile encryption key has timed out"


View products that this article applies to.

Symptoms

Consider the following scenario: On a computer that has Microsoft Commerce Server 2009 installed, you run the Microsoft SharePoint Commerce Services Configuration Wizard (SharePointCommerceServicesConfiguration.exe) to create a default site or a contemporary site. In this scenario, the wizard does not create the site successfully. Additionally, the following error message is logged:

The job creating the profile encryption key has timed out.

********** ERROR: The job creating the profile encryption key has timed out.

STACK: at Microsoft.Commerce.Portal.Setup.CommandObjects.CreateProfileKeyCommand.Execute()

at Microsoft.Commerce.Portal.Setup.UI.Confirmation.Timer_Tick(Object sender, EventArgs e)

The job creating the profile encryption key has timed out.

STACK: at Microsoft.Commerce.Portal.Setup.CommandObjects.CreateProfileKeyCommand.Execute()

at Microsoft.Commerce.Portal.Setup.UI.Confirmation.Timer_Tick(Object sender, EventArgs e).

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Cause

The issue occurs because the CreateProfileKeyCommand.Execute() method that the wizard uses sets the time-out limit to 10 seconds. However, in some environments it may take longer than 10 seconds to create a profile encryption key.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Note This hotfix does not apply to Commerce Server 2009 Template Pack.

Prerequisites

There are no prerequisites for installing this hotfix package.

Restart requirement

You do not have to restart the computer after you apply this hotfix package.

Hotfix replacement information

This hotfix package does not replace a previously released hotfix package.

File Information

The English (United States) version of this hotfix uses a Microsoft Windows Installer package to install the hotfix. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerce.portal.setup.dll1.0.20123.26214,91226-Sep-201021:37x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about how to configure SharePoint Commerce Services, visit the following MSDN webpage:

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbpubtypekc, kbsurveynew, kb

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Article Info
Article ID : 2421688
Revision : 2
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 326