Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may get an error message when trying to load or save a SSIS package


View products that this article applies to.

Symptoms

SQL Server integration Services (SSIS) packages may fail to load or to save in Business Intelligence Development Studio (BIDS) or from other SSIS runtime applications such as DTExec.exe with the following error:

Error:
DTS_E_SAVEPACKAGEFILE 
0xC001100F
-1073672177
Failed to save package file "<filename>" with error <HResult>"<Operating system error>".

The <filename> may be the name your .dtsx package file, or a .tmp file in the users temporary folder as designated by the temp environment variable.

The inner HResult error listed within the text of the error may vary depending on the scenario and it could be one of the following:
  • 0x80004005 "Unspecified error".
  • 0x8002802B "Element not found.''
  • 0x80029C4A "Error loading type library/DLL.".
  • 0x80030002 "%1 could not be found."
  • 0x80040154 "Class not registered".
  • 0x80040155 "Interface not registered"
  • 0x80070002 "The system cannot find the file specified"
In addition, you may receive additional error messages similar to the following:

Error when loading a package in Business Intelligence Development Studio (BIDS) :

DTS_E_DTPXMLDOMCREATEERROR
Unable to instantiate XML DOM document, please verify that MSXML binaries are properly installed and registered.

Error when loading a package:

0xC0010018
-1073676264
DTS_E_PERSISTENCEERROR
Error loading value "__" from node "__".

Error when saving a package:

Failed to save package file "C:\Documents and Settings\username\Local 
Settings\Temp\tmp98.tmp" with error 0x80028028. "Element not found.".

Error when exporting a package:

Library not registered. (Exception from HRESULT: 0x8002801D
(TYPE_E_LIBNOTREGISTERED)) (Microsoft.SqlServer.DTSRuntimeWrap)
================
Detailed info:
{
Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)) (Microsoft.SqlServer.DTSRuntimeWrap)
------------------------------
Program Location:
at Microsoft.SqlServer.Dts.Runtime.Application.SaveToDtsServer(Package pPackage, IDTSEvents pEvents, String sPackagePath, String sServerName)
at
Microsoft.SqlServer.Dts.ObjectExplorerUI.ImportPackageAsAction.ImportPackage(ImportPackageAsForm dlg)
===================================
Library not registered. (Exception from HRESULT: 0x8002801D
(TYPE_E_LIBNOTREGISTERED)) (Microsoft.SqlServer.DTSRuntimeWrap)
------------------------------
Program Location:
at
Microsoft.SqlServer.Dts.Runtime.Wrapper.ApplicationClass.SaveToDtsServer(IDTSPackage90 pPackage, IDTSEvents90 pEvents, String bstrPackagePath, String bstrServerName)
at
Microsoft.SqlServer.Dts.Runtime.Application.SaveToDtsServer(Package pPackage, IDTSEvents pEvents, String sPackagePath, String sServerName)
}

Error when deploying a package to SQL Server:

Package Installation Wizard:
"Could not save the package <FileName> to SQL Server <Server>."


↑ Back to the top


Cause

The error usually occurs when you either have a corrupt or a damaged installation of MSXML. The root cause of MSXML corruption may be related to remnants of previous version of MSXML that have been uninstalled from the system as discussed in the following article:

322129 PRB: MSXML TypeLib Version Information in Registry Does Not Change After You Remove the 4.0 Parser

↑ Back to the top


Resolution

Use the following procedure to resolve the problem:
  1. Manually re-register the MSXML6 Dlls on the system where you are experiencing the problem by executing the following commands at a command prompt (you need to run these commands from an Administrative Command prompt on the newer operating systems.)

    On a 32-bit machine:

    regsvr32 %windir%\system32\msxml6.dll
    regsvr32 %windir%\system32\msxml3.dll

    On a 64-bit system, reregister both the 32-bit and 64-bit Dlls:

    regsvr32 %windir%\system32\msxml6.dll
    regsvr32 %windir%\system32\msxml3.dll
    regsvr32 %windir%\SysWOW64\msxml3.dll
    regsvr32 %windir%\SysWOW64\msxml6.dll
  2. Restart the failing application. For example, if BIDS is experiencing the error, close BIDS and start it again. Test the application in the same way which generated the error noted in the symptoms section.
  3. If you are still experiencing the problem after Step 2, you may need to reinstall MSXML6 and then run Windows Update to ensure that the MSXML dlls are patched with the latest security updates. You can download MSXML6 from the following location:
    http://www.microsoft.com/download/en/details.aspx?FamilyID=993c0bcf-3bcf-4009-be21-27e85e1857b1&displaylang=en



↑ Back to the top


More Information

The SSIS packages (.dtsx files) are saved in an XML document format. When you try to load or save these packages in an application like BIDS, the application depends on COM interfaces to find and instantiate these MSXML documents. The process involves reading the values and locating the associated Dlls under the IID_IXMLDOMDocument COM interface registry key located at:

HKEY_CLASSES_ROOT\Interface\{2933BF81-7B36-11D2-B20E-00C04F983E60}

The key has values that are similar to the following:

ProxyStubClsid\ (default) = {00020424-0000-0000-C000-000000000046}
ProxyStubClsid32\ (default) = {00020424-0000-0000-C000-000000000046}
TypeLib\ (default) = {F5078F18-C551-11D3-89B9-0000F81FE221}

The proxy stub class IDs are pointing to COM interfaces:

HKEY_CLASSES_ROOT\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32
(default) = C:\Windows\system32\oleaut32.dll

The Typelib GUID represents the registration of MSXML

HKEY_CLASSES_ROOT\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32 
(default) = %SystemRoot%\System32\msxml6.dll

When any of the registry keys are missing, or the key values are mismatched, or the Dlls pointed to by the registry key values (including oleaut32.dll or msxml6.dll) are missing on the system, you can experience the problem discussed in this article. You can manually inspect the above registry keys using the Registry editor (RegEdit) tool and check them for their correctness.

For additional troubleshooting, you can use the Process Monitor tool to monitor the failing application and examine the logs of the tool to see if additional registry keys are reported as NAME NOT FOUND or ACCESS DENIED.

For additional information on the COM registry keys refer to the following link on MSDN:
http://msdn.microsoft.com/en-us/library/ms688573(VS.85).aspx

For more information about the different MSXML versions that are available or included with various Microsoft products or software updates, click the following article number to view the article in the Microsoft Knowledge Base:

269238List of Microsoft XML Core Services (XML Parser) versions
 

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2416767
Revision : 2
Created on : 4/10/2020
Published on : 4/10/2020
Exists online : False
Views : 2825