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Invoices with different enterprise numbers will be grouped under the same enterprise number in the Belgian Invoice turnover report in Microsoft Dynamics AX


Symptoms

Invoices are posted in the month January for a customer with Enterprise number BTW BE 1234.567.890. The customer however merges with another company on the 20th of January and continues with a new Enterprise number BTW BE 0987.654.321. Another invoices is posted for this customer on the 27th of January.

A user must run the mandatory “Invoice turnover report” (Annual listing report) for Belgium to report total invoiced amounts to the tax authorities. 

1. The user opens menu path General ledger / Periodic / Sales tax payment / Belgian sales tax reports / Invoice turnover report. This opens the Customer invoice turnover report dialog.

2. In the From date, the user enters: 01/01/2010.

3. In the To date, the user enters: 31/01/2010.

4. The user clicks button OK to generate the report

The report shows all the invoice amounts per Enterprise number. For this particular customer however, the total invoice amounts is being shown for Enterprise number BTW BE 0987.654.321 only. The invoice posted for this customer before changing the Enterprise number on the 20th of January is not listed using the old Enterprise number BTW BE 1234.567.890, but uses the new Enterprise number BTW BE 0987.654.321 instead.

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Cause

The Belgian “Invoice turnover report” does not use Enterprise numbers stored on the invoices, but uses the Enterprise number from the customer record instead. For customers changing Enterprise number it is normally expected new customer records would be created with the new Enterprise number.

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Resolution

In cases where Enterprise number changes cannot be processed by creating a new customer, but requires changing the Enterprise number on the existing customer record, a small code change would make sure the “Invoice turnover report” will show a separate record for both the old and the new Enterprise number.
Report CustInvoicevolume_BE, method initCustVendCalcVolume, change the following line:

    custCalc.useJournalVATNum(false);

to

    custCalc.useJournalVATNum(true);

This will fetch the Enterprise number from the invoice instead of from the customer record, and will use the Enterprise number from the invoice when reporting the invoice turnover.

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More Information

The above code change will affect the invoice amounts being reported on the Invoice turnover report. It is important to know changes were implemented in AX in 2009 to allow differentiating between VAT obliged customers and non-VAT obliged customers. The Enterprise number in the customer record needed to be supplemented with prefix 'BTW' or 'TVA' (Dutch and French abbreviation for VAT). This marks the customer as VAT-obliged. Adding this prefix would include invoices from these customers on the “Invoice turnover report” (and several other Belgian legal reports). Not having this prefix would mark the customer as non-VAT obliged, and would exclude invoices from these customer on the “Invoice turnover report”. These changes can be found here:
  • For Microsoft Dynamics AX 4.0 SP2: 
    https://mbs.microsoft.com/partnersource/support/selfsupport/taxupdates/msd_ax4belgianenternumbenahnce.htm?printpage=false&stext=50400
  • For Microsoft Dynamics AX 2009: KB971129, included in Rollup 2 
    https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?scid=kb;en-us;971535
  • For Microsoft Dynamics AX 2009 SP1: KB971129, included in Rollup 2 
    https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?scid=kb;en-us;971536

These changes did however not include functionality for companies to update the Enterprise number in all existing invoices (table CustInvoiceJour) with the same prefix. When applying the change mentioned in the ‘Resolution’ section in this KB article, these existing invoices will not appear on the “Invoice turnover report” any longer, since their Enterprise number does not have the required prefix! To solve this, all existing invoices prior to the prefix changes should also be updated with the correct Enterprise number. 

Updating the existing invoices with Enterprise numbers without this prefix would not be needed
  • when these invoices would not need to be reported any longer, and
  • all existing invoices that still need to be reported in the “Invoice turnover report” are already showing the correct Enterprise number

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Keywords: kbmbspartner, kbsurveynew, kb

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Article Info
Article ID : 2412980
Revision : 1
Created on : 1/7/2017
Published on : 8/5/2011
Exists online : False
Views : 165