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Over maximum calculation is incorrect for task maximums if there is more than one over maximum account assigned to the same task in Microsoft Dynamics SL


Symptoms

Consider the following scenario in Project Controller in Microsoft Dynamics SL 7.0:
  • You enter a value in the Max Amount box in the Project Maximums (PA.PMM.00) screen for two or more account categories for the same task.
  • You use the Allocation Processor (PA.PRO.00) screen to book a project transaction to one of the account categories that has a max amount defined that exceeds that max amount. The overmax amount is booked correctly to the overmax account.
  • You use the Allocation Processor (PA.PRO.00) screen to book a second project transaction to the same account category that has a max defined.
In this scenario, you notice that Project Allocator incorrectly books the overmax amount of the original transaction and the new transaction to the overmax account. This causes the overmax account to be booked for more than expected.

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Cause

This problem occurs because all overmax calculations after the initial calculation ignore previous over maximum amounts that were calculated.

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Resolution

Hotfix information for Microsoft Dynamics SL

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics SL Service Pack that contains this hotfix as specified in the "Status" section in this article.

To resolve this problem, click the "View and request hotfix downloads" link at the top of this article to obtain the hotfix.

Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft website:

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.


Microsoft Dynamics SL 7.0 Feature Pack 1 (FP1)
Changed filesDateFile version
PAPRO00.exe09-Sept 20107.3.40909

Installation information

Install this hotfix by following the installation instructions that are included in the hotfix download.

Prerequisites

For information about the prerequisites for this hotfix, see the installation instructions that are included in the hotfix download.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

You cannot remove this hotfix.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was reported as issue number 22161 and 22203.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Article Info
Article ID : 2411531
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 115