Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot open a public folder item when the server that holds the public folder database is stopped in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have several public folder databases that are installed on several Microsoft Exchange Server 2010 servers.
  • You configure public folder replication between the public folder databases.
  • You configure the database of a mailbox to point to a public folder database on another server.
  • The public folder database that is specified cannot be accessed.
  • You connect to the mailbox by using a MAPI client application, and you try to open a public folder item.  
In this scenario, you cannot open the public folder item. Additionally, the user interface of the MAPI client application may be corrupted.

↑ Back to the top


Cause

This problem occurs because Exchange Server 2010 does not support that the MAPI client application calls that look for an alternative public folder when the default public folder database is unavailable. Therefore, the MAPI client application keeps trying to connect to the default public folder database instead of trying to connect to other public folder databases in the referral list.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2425179 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 1

Note Client redirection occurs only if the server that hosts the specified public folder database is not available. When the server that hosts the public folder is available, client redirection does not occur if a public folder database is dismounted. In this scenario, the client cannot open a public folder even when the update is installed.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kbhotfixrollup, kbentirenet, kb

↑ Back to the top

Article Info
Article ID : 2409597
Revision : 1
Created on : 1/7/2017
Published on : 11/22/2011
Exists online : False
Views : 339