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The System.FormatException error may be returned in an application when you call the DateTime.Parse method


View products that this article applies to.

Symptoms

Consider the following scenario.
  • You have an application that uses the DateTime.Parse method or the DateTime.TryParse method. For example, you have an ASP.NET application that uses the DateTime.Parse method or the DateTime.TryParse method.
  • You run this application on a computer that is running Windows Server 2003.
In this scenario, the DateTime.Parse method may return the System.FormatException error. Additionally, the DateTime.TryParse method may incorrectly return the time of 12:00 noon if the first parameter of the method is an empty string.

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Cause

This issue occurs because one or both of the following property values are set to an empty string:
  • The value of the AMDesignator property
  • he value of the PMDesignator property
This problem may also occur for ASP.NET applications. For ASP.NET applications, this issue occurs because one or both property values are set to an empty string when ASP.NET initializes an application domain.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kernel32.dll5.2.3790.47711,042,94408-Sep-201017:14x86
For all support x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kernel32.dll5.2.3790.47711,513,98408-Sep-201014:53x64SP2Not Applicable
Wkernel32.dll5.2.3790.47711,014,78408-Sep-201014:53x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kernel32.dll5.2.3790.47711,983,48808-Sep-201014:54IA-64SP2Not Applicable
Wkernel32.dll5.2.3790.47711,014,78408-Sep-201014:54x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbfix, kbexpertiseadvanced, KB2404988

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Article Info
Article ID : 2404988
Revision : 1
Created on : 10/21/2010
Published on : 10/21/2010
Exists online : False
Views : 214