Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Web Client service crashes in Windows Server 2003 when a user logs off, and the UPHClean utility is used to unload the user profile


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • You use the User Profile Hive Cleanup Service (UPHClean) utility to unload user profiles when users log off from the computer.
  • You have an application that accesses a Web Distributed Authoring and Versioning (WebDAV) shared folder by using the Web Client service.
  • A user logs off.
In this scenario, the Web Client service may crash. When this crash occurs, other users on the computer cannot access the WebDAV shared folders any longer.

↑ Back to the top


Cause

When a user logs off, the UPHClean utility deletes some related registry keys in this user's profile. If the Web Client service tries to access one key that is deleted in the user's profile, the read operation fails. However, the Web Client service does not handle the read failure correctly, and then the service returns success by using an incorrect value. In this case, the Web Client service crashes when the incorrect value is accessed.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your must be running Windows Server 2003 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Mswsock.dll5.2.3790.4772257,02409-Sep-201012:14x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mswsock.dll5.2.3790.4772493,05609-Sep-201010:00x64SP2Not applicable
Wmswsock.dll5.2.3790.4772234,49609-Sep-201010:00x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mswsock.dll5.2.3790.4772789,50409-Sep-201010:00IA-64SP2Not applicable
Wmswsock.dll5.2.3790.4772234,49609-Sep-201010:00x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the User Profile Hive Cleanup Service utility, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2404563

↑ Back to the top

Article Info
Article ID : 2404563
Revision : 3
Created on : 10/14/2010
Published on : 10/14/2010
Exists online : False
Views : 264