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The brightness setting for the display in the "Plugged in" profile is changed after you restart a Windows 7-based portable computer that is running on battery power


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a portable computer that is running Windows 7.
  • You configure the brightness settings for the display in the active power plan. You set different brightness levels for the "On battery" and the "Plugged in" profiles in the power plan.
  • You restart the computer while the computer is running on battery power.
  • You view the brightness settings for the display.
In this scenario, the brightness setting for the "Plugged in" profile is unexpectedly changed to the brightness setting of the "On battery" profile. However, this issue does not occur if you restart the computer while it is running on AC power.

Note To view the brightness settings for the display, open the Power Options item in Control Panel, click Change plan settings for the current power plan, click Change advanced power settings, expand Display, and then expand Display brightness.

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Cause

This issue occurs because of a specific race condition in the power service.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows 7 Service Pack 1 (SP1).

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.20xxx
    Windows 7RTMLDR
    6.1.760
    1.21xxx
    Windows 7SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Umpo.dll6.1.7600.20880119,80814-Jan-201105:15x86
Umpo.dll6.1.7601.21641119,80814-Jan-201105:38x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Umpo.dll6.1.7600.20880163,84014-Jan-201106:14x64
Umpo.dll6.1.7601.21641163,84014-Jan-201106:23x64

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Workaround

To work around this issue, manually change the brightness setting for the display. Or, run the computer on AC power to correct the brightness setting.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,773
Date (UTC)14-Jan-2011
Time (UTC)16:30
PlatformNot Applicable
File nameX86_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.20880_none_5e65801ec6e8fe10.manifest
File versionNot Applicable
File size15,950
Date (UTC)14-Jan-2011
Time (UTC)05:51
PlatformNot Applicable
File nameX86_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21641_none_60781d1ec3ee138f.manifest
File versionNot Applicable
File size15,950
Date (UTC)14-Jan-2011
Time (UTC)06:13
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.20880_none_ba841ba27f466f46.manifest
File versionNot Applicable
File size15,954
Date (UTC)14-Jan-2011
Time (UTC)06:57
PlatformNot Applicable
File nameAmd64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21641_none_bc96b8a27c4b84c5.manifest
File versionNot Applicable
File size15,954
Date (UTC)14-Jan-2011
Time (UTC)07:15
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,215
Date (UTC)14-Jan-2011
Time (UTC)16:30
PlatformNot Applicable
File nameWow64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7600.20880_none_c4d8c5f4b3a73141.manifest
File versionNot Applicable
File size12,100
Date (UTC)14-Jan-2011
Time (UTC)05:43
PlatformNot Applicable
File nameWow64_microsoft-windows-usermodepowerservice_31bf3856ad364e35_6.1.7601.21641_none_c6eb62f4b0ac46c0.manifest
File versionNot Applicable
File size12,100
Date (UTC)14-Jan-2011
Time (UTC)06:04
PlatformNot Applicable

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Keywords: kb, kbsurveynew, kbexpertisebeginner, kbautohotfix, kbhotfixserver, kbqfe, kbfix

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Article Info
Article ID : 2397190
Revision : 1
Created on : 1/7/2017
Published on : 2/12/2011
Exists online : False
Views : 199