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IShareEngine fails in a Windows Home Server-based computer when you publish a share


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Home Server.
  • You�join the computer to HomeGroup.
  • You create a share by using the NetShare APIs in process�A in Windows Home Server.
  • You call the IShareEngine�function and try to publish the share that was previously shared to process�A in process�B. Process B�contains a stable cache of server message block (SMB) shares.
In this scenario, the share-publishing operation fails.

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Cause

This issue occurs because the IShareEngine->PublishItems function does not query the latest share cache. Instead, it tries to share a folder that is already shared. This behavior causes a failure to occur during the publishing process.

Notes
  • When you try to publish a share, the IShareEngine::Share�function is called. This function determines whether a share already exists through the SMB share cache. If a share exists, the function sets access control lists (ACLs). Otherwise, the function tries to create a share by using the�NetShareAdd function.
  • After the share is created in process A, the SMB share cache of process B is not updated. Then, the system calls _CreateShare to create the share again because the cache informs the function that the share does not exist.
  • NetShareAdd fails because a share already exists. Therefore, CShareEngine does not add the share to the list of items to be published.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Home Server.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Home Server file information notes
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately�in the "Additional file information for Windows Home Server" section. MANIFEST files and the associated security catalog (.cat) files, are very important for maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Home Server
File nameFile versionFile sizeDateTimePlatform
Ntshrui.dll6.1.7600.20787442,88021-Aug-201006:52x86
For all supported x64-based versions of Windows Home Server
File nameFile versionFile sizeDateTimePlatform
Ntshrui.dll6.1.7600.20787509,95221-Aug-201007:24x64
Ntshrui.dll6.1.7600.20787442,88021-Aug-201006:52x86
For all supported IA-64-based versions of Windows Home Server
File nameFile versionFile sizeDateTimePlatform
Ntshrui.dll6.1.7600.20787897,53621-Aug-201006:29IA-64
Ntshrui.dll6.1.7600.20787442,88021-Aug-201006:52x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Home Server

Additional files for all supported x86-based versions of Windows Home Server
File nameX86_558afe2337a35fa32e3d3d5006418aca_31bf3856ad364e35_6.1.7600.20787_none_6da9c41ee1983b61.manifest
File versionNot applicable
File size695
Date (UTC)21-Aug-2010
Time (UTC)12:15
PlatformNot applicable
File nameX86_microsoft-windows-ntshrui_31bf3856ad364e35_6.1.7600.20787_none_5c71a7a576ce246b.manifest
File versionNot applicable
File size30,251
Date (UTC)21-Aug-2010
Time (UTC)07:21
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Home Server
File nameAmd64_59e5258e45e2a18b067223a351da1112_31bf3856ad364e35_6.1.7600.20787_none_1cef901a7f05af59.manifest
File versionNot applicable
File size699
Date (UTC)21-Aug-2010
Time (UTC)12:15
PlatformNot applicable
File nameAmd64_ff585d78373753ebe8568d5f3e063cb5_31bf3856ad364e35_6.1.7600.20787_none_2c943bf86f177633.manifest
File versionNot applicable
File size1,040
Date (UTC)21-Aug-2010
Time (UTC)12:15
PlatformNot applicable
File nameAmd64_microsoft-windows-ntshrui_31bf3856ad364e35_6.1.7600.20787_none_b89043292f2b95a1.manifest
File versionNot applicable
File size30,255
Date (UTC)21-Aug-2010
Time (UTC)08:28
PlatformNot applicable
File nameWow64_microsoft-windows-ntshrui_31bf3856ad364e35_6.1.7600.20787_none_c2e4ed7b638c579c.manifest
File versionNot applicable
File size30,255
Date (UTC)21-Aug-2010
Time (UTC)07:15
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Home Server
File nameIa64_cf8a876959ee853b1a60a50b29a6e37a_31bf3856ad364e35_6.1.7600.20787_none_02991e321d4bc793.manifest
File versionNot applicable
File size1,038
Date (UTC)21-Aug-2010
Time (UTC)12:15
PlatformNot applicable
File nameIa64_microsoft-windows-ntshrui_31bf3856ad364e35_6.1.7600.20787_none_5c734b9b76cc2d67.manifest
File versionNot applicable
File size30,253
Date (UTC)21-Aug-2010
Time (UTC)08:13
PlatformNot applicable
File nameWow64_microsoft-windows-ntshrui_31bf3856ad364e35_6.1.7600.20787_none_c2e4ed7b638c579c.manifest
File versionNot applicable
File size30,255
Date (UTC)21-Aug-2010
Time (UTC)07:15
PlatformNot applicable

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Keywords: KB2388028, kbqfe, kbexpertiseinter, kbsurveynew, kbhotfixserver, kbautohotfix, kbfix

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Article Info
Article ID : 2388028
Revision : 2
Created on : 10/15/2010
Published on : 10/15/2010
Exists online : False
Views : 247