Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

WebDav mapped drive reports incorrect drive capacity


View products that this article applies to.

Symptom

Consider the scenario with a WebDAV mapped drive on a Windows client. The drive's capacity is reported different than the actual capacity of the disk on the file server.

↑ Back to the top


Cause

Research on WebDAV protocol RFCs and verification from Microsoft's product team confirmed WebDAV protocol doesn’t support querying server’s disk capacity. With this constrain of WebDAV protocol, Windows client sets WebDAV mapping drive’s capacity the same as its System Drive.  

↑ Back to the top


Resolution

This is by design. A WebDAV mapped drive's capacity is set to match the client machine's System drive capacity. This means that the capacity you get from a WebDAV mapped drive is the same as your local System drive. System drive is where Windows is installed.

Example:

On a Windows client:

System drive C:\

Free disk space: 39.9 GB

Used Disk Space: 11.2 GB


WebDAV mapped drive Y:\

Free disk space: 39.9 GB

Used Disk Space: 11.2 GB

↑ Back to the top


More Information

For more information about WebDAV mapped drives on Windows clients, reference http://www.iis.net/ConfigReference/system.webServer/webdav

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2386902
Revision : 1
Created on : 1/7/2017
Published on : 4/27/2012
Exists online : False
Views : 707