Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: ESEUTIL /P Aborts with -1605, JET_errKeyDuplicate


View products that this article applies to.

Symptoms

While processing an EDB database file during repair, Eseutil /P may prematurely exit processing the file, reporting:
Operation terminated with error -1605 (JET_errKeyDuplicate, Illegal duplicate key) after xxx.xxx seconds.

↑ Back to the top


Cause

Under certain conditions, repair might rebuild b-trees incorrectly.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:

Component: Ese.dll

File nameVersion
Ese.dll5.5.2650.6

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: KB237422, kbqfe, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 237422
Revision : 4
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 309