Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Information Store or Directory Service Appear Hung


View products that this article applies to.

This article was previously published under Q236426

↑ Back to the top


Symptoms

  • The information store service becomes unresponsive. Users are unable to log onto mailboxes, and Performance Monitor may show %Processor Utilization for Store.exe at 0 percent.
  • The directory service becomes unresponsive. Various operations, such as resolving a name to a mailbox in the global address list, or checking a name during creation of a mailbox profile stop responding (hang) when users attempt to perform them. In addition, Performance Monitor may show %Processor Utilization for Dsamain.exe at 0 percent.

↑ Back to the top


Cause

ESE (Jet) hangs because all threads are waiting to acquire a resource that is owned by another thread. The decision used by threads as to which resources to acquire is based in part on a timestamp, and the timestamp comparison is being performed incorrectly. This incorrect comparison can cause the owning thread not to release the lock on the resource and leave all threads waiting.

The symptoms noted above are usually dependent on system uptime. Although this problem is not reproducible, documented cases encountered this problem on Exchange Server computers running for 30 days or more.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014� XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this feature should have the following file attributes or later:

Component: ESE

Collapse this tableExpand this table
File nameVersion
Ese.dll5.5.2608

This hotfix has been posted to the following Internet location as Psp2esei.exe:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Serverversion 5.5. This problem was first corrected in Microsoft Exchange Server version 5.5 Service Pack 3.

↑ Back to the top


Keywords: KB236426, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 236426
Revision : 6
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 323