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XIMS: WHO Command with Wildcard Characters Causes Server to End Portal Connection


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This article was previously published under Q236311
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

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Symptoms

If you repeatedly send the WHO command with a wildcard character as a parameter to a Microsoft Exchange Chat Service computer, and the server is connected to another Microsoft Exchange Chat Service computer through a portal, the second server may eventually end the portal connection unexpectedly. This includes the following combinations of the asterisk (*) and question mark (?) wildcard characters, which match all strings:
  • *
  • ?*
  • '*
  • '?*
Note that this problem occurs if the wildcard character (or combination of wildcard characters) is the only parameter or if it is included in a list of multiple parameters.

In addition, if you send the WHO command with a parameter terminated by a comma, the server performs a search based on the specified parameter, and then performs an additional search as if a wildcard character had also been specified. This may cause the above problem to occur.

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Cause

This problem occurs when the output saturation limit on the server to which you are connected is very high. When you send the WHO command with a wildcard character, the command returns a large amount of data. If the output saturation limit is very high, the output buffer on the server to which you are connected may become very large, which in turn causes the portal buffer on the second server to become very large. If the buffers become large enough, the second server ends the portal connection.

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Resolution

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014� XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:

Component: Chat Service

Collapse this tableExpand this table
File nameVersion
Chatsvc.exe5.5.2632.0

After you apply the fix, configure the server to ignore WHO commands that are sent with a wildcard character as a parameter. To do so:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ChatSvc\Parameters
  3. If the RestrictWho value already exists under the above key, on the Edit menu, click DWORD, type 2, and then click OK.

    If the RestrictWho value does not already exist, on the Edit menu, click Add Value, and then add the following registry value:
    Value Name: RestrictWho
    Data Type: REG_DWORD
    Value: 2
  4. Quit Registry Editor.

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Workaround

To work around this problem, lower the output saturation limit on the server:
  1. Start the Microsoft Management Console (MMC). To do so, click Start, point to Programs, point to Microsoft Exchange Chat Service, and then click Chat Service Manager.
  2. In the left pane, click the User Classes folder under the appropriate server. Note that the server appears under the Microsoft Exchange Chat Service folder.
  3. In the right pane, click a user class, click Action, and then click Properties.
  4. Click the Settings tab, type a smaller value in the Output saturation limit (kilobytes) box, and then click OK.
  5. Repeat steps 3 and 4 for any additional user classes that are listed in the right pane.

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

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More information

This problem does not occur when the output saturation limit is low, because the server automatically ends the connection to the client before the buffers become too large.

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Keywords: KB236311, kbfix, kbbug, kbqfe, kbhotfixserver

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Article Info
Article ID : 236311
Revision : 8
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 281