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"Permission Denied" error when you run the rsh command in Utilities and SDK for SUA on a computer that is running Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Utilities and SDK for Subsystem for UNIX-based Applications (SUA) on a computer that is running Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2.
  • You run the following rsh command on the computer to connect to a Remote Shell service (RSH) server:
    rsh -l <UserName> <IP/HostName> <Command>

    Note The <UserName> user account does not have administrator rights on the RSH server.
In this scenario, you receive an error message that resembles the following on the computer:
Permission Denied.
Additionally, an error message that resembles the following is logged on the RSH server:
Login incorrect.

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Cause

This issue occurs because the rsh command does not send the user name to the RSH server correctly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2. Additionally, you must have Utilities and SDK for Subsystem for UNIX-based Applications (SUA) installed.

Installation information

When you install this hotfix, select one of the following options:
  • Repair or reinstall
  • Repair
When you install the hotfix, you may receive a dialog box that contains the following message:
Click OK to try again, or enter an alternate path to a folder containing the installation package ‘setup.msi’ in the box below
To resolve this issue, perform a full installation of the hotfix. To do this, follow these steps:
  1. Download Utilities and SDK for SUA from the appropriate website, depending on your operating system:
  2. Click the Setup button on the Wizard and wait for the Unzip process to finish.
  3. Save the Setup.msi file to a permanent location.
    Note If you are using Windows 7 or Windows Server 2008 R2, you can find the file in the following path:
    C:\Users\<UserName>\AppData\Local\Temp\2\WZSE0.TMP
  4. Cancel the Wizard, and then type the path of the permanent location directory in the dialog box that you received before.
  5. Click the OK button. The hotfix will now install successfully.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
For Utilities and SDK for SUA on all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rsh10.0.6030.22724119,80824-Aug-201016:09Not applicable
For Utilities and SDK for SUA on all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rsh10.0.6030.22748128,51224-Aug-201016:44Not applicable
For Utilities and SDK on all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Rsh10.0.7600.20748120,32017-Aug-201015:22Not applicable
For Utilities and SDK on all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Rsh10.0.7600.20748119,29617-Aug-201015:29Not applicable

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Workaround

To work around this issue, add the -D option to the rsh command. For example, run the following command:
rsh -D -l <username><ip><command>

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2360829
Revision : 2
Created on : 4/10/2020
Published on : 4/10/2020
Exists online : False
Views : 327