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The StrongCRLCheck setting does not work on a Windows Server 2008 R2-based computer that has the RRAS role service installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Routing and Remote Access Service (RRAS) role on a server that is running Windows Server 2008 R2.
  • You configure the server to accept Layer Two Tunneling Protocol with IPsec (L2TP/IPsec) connections.
  • You run the Netsh ipsec dynamic set config property=strongcrlcheck value=2 command to configure the StrongCRLCheck setting on the server.
  • You revoke a certificate on a client computer. The certificate is used to make L2TP/IPsec connections to the RRAS server.
  • You establish an L2TP/IPsec connection from the client computer to the server.
In this scenario, the connection to the RRAS server is successful. However, you expect that the client computer cannot connect to the server.

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Cause

The issue occurs because the Remote Access Service (RAS) ignores the StrongCRLCheck setting.

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Resolution

Note After you install the hotfix, you have to create an L2tpCRLCheckLevel registry subkey to configure the level of check to be performed for L2TP/IPsec connections. For more information about how to create this registry subkey, see the "Registry information" section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
After you install the hotfix, you have to create a registry subkey to configure the level of check to be performed for L2TP/IPsec connections.
Note This registry subkey does not affect Internet Key Exchange version 2 (IKEv2) connections.
To do this, follow these steps:
  1. Click Start
    , type regedit in the Search programs and files box, and then press ENTER.
    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type L2tpCRLCheckLevel, and then press ENTER.
  5. Right-click L2tpCRLCheckLevel, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
    Note
    • A value of 0 disables CRL checking.
    • A value of 1 enables the default level of CRL checking. When this level of CRL checking is performed, certificate validation fails only if the certificate is revoked and the CRL exists in the client�s CRL cache.
    • A value of 2 enables�the StrongCRLCheck setting. This means that certification validation fails if any error is encountered during CRL processing.
  7. Exit Registry Editor.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Rasmans.dll6.1.7600.20798344,06411-Sep-201008:47x64
For all supported IA-64-based versions of Windows Server 2008 R2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
961361 The IPsec client can connect to a Windows Server 2003-based server even when the StrongCRLCheck attribute is set to 1 and a revoked certificate exists in the certificate chain
For more information about Internet Protocol security (IPsec), visit the following Microsoft webpage.

For more information about Netsh commands for Internet Protocol security (IPsec), visit the following Microsoft webpage.

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_3120369a3fb546e30defd460ed452f1d_31bf3856ad364e35_6.1.7600.20798_none_5dd5221718b908ac.manifest
File versionNot applicable
File size705
Date (UTC)14-Sep-2010
Time (UTC)07:31
PlatformNot applicable
File nameAmd64_microsoft-windows-rasmanservice_31bf3856ad364e35_6.1.7600.20798_none_fb345b57d37c8935.manifest
File versionNot applicable
File size12,904
Date (UTC)11-Sep-2010
Time (UTC)09:18
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,875
Date (UTC)14-Sep-2010
Time (UTC)07:31
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2

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Keywords: KB2351254, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2351254
Revision : 2
Created on : 1/4/2011
Published on : 1/4/2011
Exists online : False
Views : 338