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The logon screen appears two times when you resume a Windows 7-based or Windows Server 2008 R2-based computer from Sleep (S3) or from Hibernation (S4)


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You install hotfix KB976427.
  • You enable the Require a password on wakeup option.
  • You resume the computer from Sleep (S3) or from Hibernation (S4).

In this scenario, the logon screen may appear two times. Therefore, you have to enter your credentials two times.


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Cause

This issue occurs when there are multiple pending lock signals to be processed when the user is logging in. In this situation, the WinLogon state machine logs the user off.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.16xxxWindows 7 and Windows Server 2008 R2RTMGDR
    6.1.760 0.20xxxWindows 7 and Windows Server 2008 R2RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.1.7600.16671285,69608-Sep-201004:26x86
Winlogon.exe6.1.7600.20795286,20808-Sep-201004:28x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.1.7600.16671389,63208-Sep-201005:32x64
Winlogon.exe6.1.7600.20795390,65608-Sep-201005:23x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.1.7600.16671786,43208-Sep-201004:04IA-64
Winlogon.exe6.1.7600.20795788,99208-Sep-201004:05IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the WinLogon states, visit the following Microsoft website: For more information about KB976427, click the following article number to view the article in the Microsoft Knowledge Base:
976427 Computers that are running Windows 7 or Windows Server 2008 R2 stop responding at a black screen if a screen saver is enabled

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,881
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameX86_88b2caabeec04e83f92884ee90927b53_31bf3856ad364e35_6.1.7600.16671_none_e2210f22c7c37cd6.manifest
File versionNot applicable
File size696
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameX86_f5ebf78b9e868d37d1eafd3934017457_31bf3856ad364e35_6.1.7600.20795_none_3a4c01b02e621fa9.manifest
File versionNot applicable
File size696
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.16671_none_6fa02bb03640878e.manifest
File versionNot applicable
File size16,217
Date (UTC)08-Sep-2010
Time (UTC)05:05
PlatformNot applicable

File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.20795_none_701829cb4f6ac496.manifest
File versionNot applicable
File size16,217
Date (UTC)08-Sep-2010
Time (UTC)05:28
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_2e45d0f6ba8ba030dab96c83605c7b5b_31bf3856ad364e35_6.1.7600.16671_none_5a092d378c5d1421.manifest
File versionNot applicable
File size700
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameAmd64_e62f3e58c75af4f41d5d695882816e98_31bf3856ad364e35_6.1.7600.20795_none_a7493f3771923ed5.manifest
File versionNot applicable
File size700
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameAmd64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.16671_none_cbbec733ee9df8c4.manifest
File versionNot applicable
File size16,223
Date (UTC)08-Sep-2010
Time (UTC)06:17
PlatformNot applicable

File nameAmd64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.20795_none_cc36c54f07c835cc.manifest
File versionNot applicable
File size16,223
Date (UTC)08-Sep-2010
Time (UTC)06:09
PlatformNot applicable

File nameUpdate.mum
File versionNot applicable
File size2,115
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_1594351ec02e6be0fa1453db50aaa78f_31bf3856ad364e35_6.1.7600.16671_none_4cfac998a6a4bded.manifest
File versionNot applicable
File size698
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameIa64_70b0c937d2510115cbd619a989b8fd94_31bf3856ad364e35_6.1.7600.20795_none_94677f6efc841b2f.manifest
File versionNot applicable
File size698
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

File nameIa64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.16671_none_6fa1cfa6363e908a.manifest
File versionNot applicable
File size16,220
Date (UTC)08-Sep-2010
Time (UTC)05:44
PlatformNot applicable

File nameIa64_microsoft-windows-winlogon_31bf3856ad364e35_6.1.7600.20795_none_7019cdc14f68cd92.manifest
File versionNot applicable
File size16,220
Date (UTC)08-Sep-2010
Time (UTC)05:46
PlatformNot applicable

File nameUpdate.mum
File versionNot applicable
File size1,690
Date (UTC)09-Sep-2010
Time (UTC)00:51
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2345131

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Article Info
Article ID : 2345131
Revision : 1
Created on : 10/13/2010
Published on : 10/13/2010
Exists online : False
Views : 301