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The CD or DVD device is not fully removed after you perform a surprise removal of a device on a computer that is running Windows Server 2008 R2 if the device is used on a hosted virtual machine


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Hyper-V role on a fault-tolerant system that is running Windows Server 2008 R2.
  • The fault-tolerant system has a CD or DVD device.
  • The CD or DVD device is used on a running virtual machine (VM) that is hosted on the fault-tolerant system.
  • You perform a surprise removal of the CD or DVD device.

    Note After a device is removed on a primary node, the fault-tolerant system should make the device available on a secondary node.
In this scenario, the CD or DVD device is not fully removed. Therefore, the CD or DVD device is not available on a secondary node of the fault-tolerant system.

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Cause

This issue occurs because of an error in the Virtual Machine Worker process (Vmwp.exe). When the Vmwp.exe process receives a notification of a surprise removal for a CD or DVD device, the process does not close the corresponding handle. Therefore, the CD or DVD device is not fully removed.

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Resolution

After you install this hotfix, the Vmwp.exe process closes the corresponding handle for the CD or DVD device when the device is removed. Therefore, the device is released from the primary node immediately.�

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2. Additionally, you must have the Hyper-V role installed.�

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information note
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Vmwp.exe6.1.7600.207743,593,21607-Aug-201002:57x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_90fbf48a8077fdf97493f6e77d092d19_31bf3856ad364e35_6.1.7600.20774_none_b77251542b4f22dd.manifest
File versionNot applicable
File size703
Date (UTC)07-Aug-2010
Time (UTC)07:31
PlatformNot applicable

File nameAmd64_microsoft-hyper-v-vstack-vmwp_31bf3856ad364e35_6.1.7600.20774_none_91c8f20c9290110f.manifest
File versionNot applicable
File size256,418
Date (UTC)07-Aug-2010
Time (UTC)05:50
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,462
Date (UTC)07-Aug-2010
Time (UTC)07:31
PlatformNot applicable

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Keywords: KB2307198, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2307198
Revision : 1
Created on : 8/23/2010
Published on : 8/23/2010
Exists online : False
Views : 274