Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when an Outlook 2003 client tries to open multiple shared calendars in Exchange Server 2010: "The connection to the Microsoft Exchange server in unavailable. Outlook must be online or connected to complete this action"


View products that this article applies to.

Symptoms

When a Microsoft Office Outlook 2003 client tries to open multiple shared calendars whose mailboxes are on a server that is running Microsoft Exchange Server 2010, you receive the following error message:

The connection to the Microsoft Exchange server in unavailable. Outlook must be online or connected to complete this action.

This problem does not occur in a Microsoft Office Outlook 2007 client or in a later-version client. And, this problem does not occur if you move the target mailboxes to a server that is running an earlier version of Exchange Server.

↑ Back to the top


Cause

This problem occurs because of Outlook 2003 dependencies on reference Mailbox Database support. This is not supported in Exchange Server 2010. Outlook 2003 clients must now reference the Exchange Server 2010 Address Book service when they open shared calendars.

In order to make Outlook 2003 connections easier to complete, we changed the mailbox server name�to give the appearance of connections to different mailboxes on different servers. Only the AddressBook service understands this changed mailbox server name. Therefore, clients that try to connect directly to Active Directory will fail to make the connection.

However, if many delegate mailboxes are being used, clients that are accessing the Address Book Service will reach a limit on the number of connections any single user can have. This exhausts the maximum number of connections available (20) specified by the default throttling policy that is associated with the user mailbox.

In this situation, Outlook 2007 clients and later-version clients do not open multiple additional connections.

↑ Back to the top


Resolution

To resolve this problem, create a custom throttling policy by using an increased value for RCAMaxConcurrency. Then, associate this custom throttling policy to the mailboxes that require Outlook 2003 clients to open multiple shared calendars.

After you make this change, wait for the Active Directory replication to finish. By default, the throttling policy should be applied after 15 minutes. To apply it immediately, restart the Microsoft Exchange RPC Client Access service on the Client Access Server (CAS).

Note�An RCAMaxConcurrency value of 100 is sufficient in typical cases in which Outlook 2003 has to open 29 shared calendars. This value may have to be increased, depending on which Outlook add-ins are installed.

Important The original release of Exchange Server 2010 allows�a maximum parameter value�for RCAMaxConcurrency�of 100. Exchange Server 2010 Service Pack 1 increases the maximum value for RCAMaxConcurrency to 2147483647.

↑ Back to the top


More information

For more information about how to create a new throttling policy, visit the following Microsoft TechNet website:For more information about Exchange Server 2010 throttling policies, visit the following Microsoft TechNet website:

↑ Back to the top


Keywords: KB2299468, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2299468
Revision : 2
Created on : 12/7/2010
Published on : 12/7/2010
Exists online : False
Views : 370