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The Hyper-V-related services cannot start on a Windows Server 2008 R2-based computer that has many processor cores and many PCI MSI-X devices


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2 with the Hyper-V role installed.
  • The computer has many processor cores and many PCI MSI-X devices. For example, the computer has 32 processor cores and 128 PCI slots.
In this scenario, the Hyper-V-related services cannot start. Additionally, if you view the properties of the Virtual Machine Bus device and the Virtualization Infrastructure Driver device in Device Manager, you receive the following error message:

This device cannot find enough free resources that it can use. If you want to use this device, you will need to disable one of the other devices on this system. (Code 12)

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Cause

This problem occurs because the two device drivers that are mentioned in the "Symptoms" section cannot register themselves into the Interrupt Descriptor Table (IDT) within the hard-coded time limitation (5 seconds). Because the IDT is large if a computer has many processor cores and many PCI MSI-X supported devices, it takes the two device drivers more than 5 seconds to find available slots in the IDT table.

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Resolution

Note After you install this hotfix, you must create a new FindBestConfigurationTimeout registry key to customize the time limitation. For more information about how to create the new registry key, see the "Registry information" section.

Note�The resolution that is provided in this article may not resolve the problem in all scenarios. For example, increasing the configuration time-out does not resolve the issue if there are no IDT entries available on any processor in the system. In this scenario, you have to reduce the number of MSI interrupts that are used to make sure that sufficient IDT space is available for all devices on the system. To do this, use one of the following methods:
  • Remove or disable devices that use MSI interrupts.
  • Change the device configurations so that the devices request fewer MSI interrupts.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 with the Hyper-V role installed.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
After you install this hotfix, you must create a registry key to customize the time limitation. To do this, follow these steps:
  1. Click Start
    , type regedit in the Search programs and files box, and then press Enter.
    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PnP
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type FindBestConfigurationTimeout, and then press Enter. �
  5. Right-click FindBestConfigurationTimeout, and then click Modify.
  6. Under Base, click Decimal.
  7. In the Value data box, type the time limitation that you want to use in milliseconds, and then click OK.
    Note�Before you create the FindBestConfigurationTimeout registry key, the default time limitation is 5,000 milliseconds. After you configure the FindBestConfigurationTimeout registry key, the maximum time limitation is the value that is specified by the registry key.
  8. Exit Registry Editor.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.207875,474,68824-Aug-201000:57x64
Ntkrnlpa.exe6.1.7600.207873,964,80021-Aug-201006:59Not applicable
Ntoskrnl.exe6.1.7600.207873,909,50421-Aug-201006:59Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about MSI-X, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_3c27554882fa688b375ebdd2a09c88b6_31bf3856ad364e35_6.1.7600.20787_none_6b76994b6d72a74c.manifest
File versionNot applicable
File size1,042
Date (UTC)25-Aug-2010
Time (UTC)17:41
PlatformNot applicable

File nameAmd64_60a91d9ade5231708f8734a7bddbd4c8_31bf3856ad364e35_6.1.7600.20787_none_97e6f418d81ffa68.manifest
File versionNot applicable
File size699
Date (UTC)25-Aug-2010
Time (UTC)17:41
PlatformNot applicable

File nameAmd64_cab9b306a6e77d7f7dfb9c520df575b3_31bf3856ad364e35_6.1.7600.20787_none_8d5b9322a818f148.manifest
File versionNot applicable
File size701
Date (UTC)25-Aug-2010
Time (UTC)17:41
PlatformNot applicable

File nameAmd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20787_none_c8b0f658e6efe2fc.manifest
File versionNot applicable
File size15,291
Date (UTC)24-Aug-2010
Time (UTC)01:54
PlatformNot applicable

File nameUpdate.mum
File versionNot applicable
File size2,114
Date (UTC)25-Aug-2010
Time (UTC)17:41
PlatformNot applicable

File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20787_none_6c925ad52e9271c6.manifest
File versionNot applicable
File size16,151
Date (UTC)21-Aug-2010
Time (UTC)07:27
PlatformNot applicable

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Keywords: KB2297652, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2297652
Revision : 2
Created on : 10/13/2010
Published on : 10/13/2010
Exists online : False
Views : 321