Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Poor printing performance in Windows 7 or in Windows Server 2008 R2 compared to the performance in Windows Vista or in Windows Server 2008


View products that this article applies to.

SYMPTOMS

On a computer that is running Windows 7 or Windows Server 2008 R2, the printing performance may be poor compared to the performance on a computer that is running Windows Vista or Windows Server 2008. Additionally, a computer that is running Windows 7 or Windows Server 2008 R2 consumes more CPU resources when you print a document.

For example, CPU usage remains at 100 percent for a long time in Task Manager when you print a document on a computer that is running Windows 7 or Windows Server 2008 R2.

↑ Back to the top


CAUSE

This issue occurs because of a performance regression in spooler behavior on single-processor systems that are running Windows 7 or Windows Server 2008 R2.

↑ Back to the top


RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20780768,51214-Aug-201004:35x86
Winprint.dll6.1.7600.1638529,69614-Jul-200901:16x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20780955,90414-Aug-201005:19x64
Winprint.dll6.1.7600.1638539,42414-Jul-200901:41x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.207802,052,60814-Aug-201004:16IA-64
Winprint.dll6.1.7600.1638590,62414-Jul-200901:50IA-64

↑ Back to the top


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_41a317bd2e1a249d7636ad63afd94b14_31bf3856ad364e35_6.1.7600.20780_none_be6cee479e848788.manifest
File versionNot applicable
File size718
Date (UTC)14-Aug-2010
Time (UTC)07:28
PlatformNot applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20780_none_3076552a0d23c6d8.manifest
File versionNot applicable
File size4,844
Date (UTC)14-Aug-2010
Time (UTC)07:31
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_41a317bd2e1a249d7636ad63afd94b14_31bf3856ad364e35_6.1.7600.20780_none_1a8b89cb56e1f8be.manifest
File versionNot applicable
File size720
Date (UTC)14-Aug-2010
Time (UTC)07:28
PlatformNot applicable
File nameAmd64_49d94added9d401ed947e1b19b1db696_31bf3856ad364e35_6.1.7600.20780_none_306849d0c8772c17.manifest
File versionNot applicable
File size722
Date (UTC)14-Aug-2010
Time (UTC)07:28
PlatformNot applicable
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20780_none_8c94f0adc581380e.manifest
File versionNot applicable
File size4,845
Date (UTC)14-Aug-2010
Time (UTC)07:34
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_47c9c30e820ac717d7a7203f4795c495_31bf3856ad364e35_6.1.7600.20780_none_fb3a20429ff156cd.manifest
File versionNot applicable
File size720
Date (UTC)14-Aug-2010
Time (UTC)07:28
PlatformNot applicable
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20780_none_3077f9200d21cfd4.manifest
File versionNot applicable
File size4,844
Date (UTC)14-Aug-2010
Time (UTC)07:28
PlatformNot applicable

↑ Back to the top


Keywords: misc_migrate_32718, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2295825, kbAudITPRO, kbAudOEM, Partner, kb

↑ Back to the top

Article Info
Article ID : 2295825
Revision : 3
Created on : 4/13/2018
Published on : 4/13/2018
Exists online : False
Views : 306