Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You experience a long startup time on a Windows 7-based computer that has an unused external SATA port


View products that this article applies to.

Symptoms

You experience a long startup time on a Windows 7-based computer that has an unused external SATA port.�

↑ Back to the top


Cause

This issue occurs because the Microsoft Advanced Host Controller Interface (AHCI) initialization timing does not align with the SATA specification.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.014,40014-Jul-200901:26x86
Amdide.sys6.1.7600.1638514,91214-Jul-200901:26x86
Atapi.sys6.1.7600.1638521,58414-Jul-200901:26x86
Ataport.sys6.1.7600.20776132,97610-Aug-201004:35x86
Cmdide.sys2.0.7.015,95214-Jul-200901:26x86
Intelide.sys6.1.7600.1638515,42414-Jul-200901:20x86
Msahci.sys6.1.7600.2077627,52810-Aug-201004:35x86
Pciide.sys6.1.7600.1638512,36814-Jul-200901:20x86
Pciidex.sys6.1.7600.1638542,56014-Jul-200901:19x86
Viaide.sys6.0.6000.17016,97614-Jul-200901:19x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.015,44014-Jul-200901:52x64
Amdide.sys6.1.7600.1638515,44014-Jul-200901:52x64
Atapi.sys6.1.7600.1638524,12814-Jul-200901:52x64
Ataport.sys6.1.7600.20776155,52810-Aug-201005:22x64
Cmdide.sys2.0.7.017,48814-Jul-200901:52x64
Intelide.sys6.1.7600.1638516,96014-Jul-200901:48x64
Msahci.sys6.1.7600.2077630,08810-Aug-201005:22x64
Pciide.sys6.1.7600.1638512,35214-Jul-200901:45x64
Pciidex.sys6.1.7600.1638548,72014-Jul-200901:45x64
Viaide.sys6.0.6000.17017,48814-Jul-200901:45x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,648
Date (UTC)10-Aug-2010
Time (UTC)08:35
PlatformNot applicable
File nameX86_mshdc.inf_31bf3856ad364e35_6.1.7600.20776_none_dda3f0f09bf1f8b2.manifest
File versionNot applicable
File size6,632
Date (UTC)10-Aug-2010
Time (UTC)08:39
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_mshdc.inf_31bf3856ad364e35_6.1.7600.20776_none_39c28c74544f69e8.manifest
File versionNot applicable
File size6,636
Date (UTC)10-Aug-2010
Time (UTC)08:42
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,658
Date (UTC)10-Aug-2010
Time (UTC)08:35
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, KB2292867

↑ Back to the top

Article Info
Article ID : 2292867
Revision : 2
Created on : 8/16/2011
Published on : 8/16/2011
Exists online : False
Views : 343