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FIX: Several issues occur when you use BizTalk Adapter for JD Edwards EnterpriseOne or BizTalk Adapter for JD Edwards OneWorld XE in BizTalk Server 2006 R2 or in BizTalk Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft BizTalk Server 2006 R2 or Microsoft BizTalk Server 2009.
  • You use one of the following adapters to exchange Business Function messages between BizTalk Server and a JD Edwards EnterpriseOne system:
    • Microsoft BizTalk Adapter for JD Edwards EnterpriseOne
    • Microsoft BizTalk Adapter for JD Edwards OneWorld XE
In this scenario, one or more of the following issues may occur.

Issue 1

After you try to send a message by using the adapter, the adapter is idle for a while and then you try to send another message. In this scenario, the adapter does not send the first message. However, the adapter sends the second message. Additionally, an event that resembles the following is logged in the Application log:

Issue 2

When you set the Max Concurrent Calls transport property to a value that is greater than 1 for the adapter, many message instances dehydrate and are not processed.

Issue 3

Periodically messages are suspended. Additionally, some event entries that resemble the following are logged in the Application log:

Event 1

Event 2

Event 3

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Cause

These issues occur because of an error in BizTalk Adapters for Enterprise Applications.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have BizTalk Adapters for Enterprise Applications (also known as BizTalk LOB Adapters) installed. Additionally, the computer should be running BizTalk Server 2006 R2 Service Pack 1 (SP1) or BizTalk Server 2009.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For BizTalk Server 2006 R2 SP1
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapters.bizutil.dll1.0.5022.13164,23208-Aug-201116:47x86
For BizTalk Server 2009
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapters.bizutil.dll1.0.5102.2156,04028-Jul-201010:30x86

How to apply this hotfix

To apply this hotfix after you install it, do the following:
  1. Manually register the Microsoft.BizTalk.Adapters.BizUtil.dll file in the global assembly cache (GAC). To do this, follow these steps.

    1. Open a Visual Studio Command Prompt or SDK Command Prompt window. Change the current directory to the following:
      %ProgramFiles%\Common Files\Microsoft BizTalk Adapters for Enterprise Applications\Bin
      Important To open a Visual Studio Command Prompt window, you must have Microsoft Visual Studio 2008 or Microsoft Visual Studio 2005 installed. To open a SDK Command Prompt window, you must have the Microsoft .NET Framework 2.0 SDK installed.
    2. At the Visual Studio Command Prompt or SDK Command Prompt window, type the following command, and then press Enter:
      gacutil /i Microsoft.BizTalk.Adapters.BizUtil.dll
  2. Create a new subkey in the registry. To do this, follow these steps:

    Warning Serious problems might occur if you change the registry incorrectly by using Registry Editor or by using another method. These problems might require you to reinstall the operating system. Microsoft cannot guarantee that these problems can be resolved. Change the registry at your own risk.
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then select the following registry key:
      For 32-bit operating system
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters

      For 64-bit operating system
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalkAdapters
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type AgentOutboundTimeout, and then press Enter.
    5. On the Edit menu, click Modify.
    6. Select Decimal, type 60000, and then click OK.
    The AgentOutboundTimeout value is used to recycle the RunTimeAgent processes after a certain time period of inactivity. We recommend that you set the value so that it is more than the time that is required for the operation to complete on the Oracle server. By default, the value is 60000 milliseconds (1 minute).

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about BizTalk Adapter for JD Edwards EnterpriseOne, visit the following Microsoft Developer Network (MSDN) website: For more information about BizTalk Adapter for JD Edwards OneWorld XE, visit the following MSDN website: For more information about the Visual Studio Command Prompt window, visit the following MSDN website:For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information on BizTalk Server hotfixes

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbexpertiseadvanced, kbsurveynew, kbbiztalk2009presp1fix, kbbtsadapters

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Article Info
Article ID : 2291479
Revision : 2
Created on : 9/10/2018
Published on : 9/11/2018
Exists online : False
Views : 338