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The backup data is corrupted when you use the Windows Backup utility to back up some SQL Server databases or the AD LDS instance data in Windows 7


View products that this article applies to.

Symptoms

When you use the Windows Backup utility on a computer that is running Windows 7, the following two issues may occur.

Issue 1

You run Microsoft SQL Server on the computer. When you use the Windows Backup utility to back up some SQL Server databases by using Volume Shadow Copy Service (VSS), the backup may be corrupted.

Issue 2

You install Active Directory Lightweight Directory Services (AD LDS) for Windows 7 on the computer. When you try to restore the AD LDS instance data backup that was created by the Windows Backup utility, the instance data is corrupted.

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Cause

These issues occurs because the Windows Backup utility relies on a hard-coded list of VSS writers. However, the VSS writers for SQL Server and for AD LDS are not used to create the backups. Therefore, the backup data is corrupted.

Note These issues may occur to some other applications that do not have the corresponding in-box VSS writers when you use the Windows Backup utility to back up data.

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Resolution

After you apply this hotfix, you can create a multi-string value that has the EnabledWriters name to specify additional VSS writers for the backup in the following path:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SPP

Notes
  • The registry value type is REG_MULTI_SZ, and the registry value is a list of writer IDs that are GUID.
  • You can run the following command at an elevated command prompt to obtain a list of subscribed VSS writers on a computer that is running Windows 7:

    vssadmin list writers
    For example, you run this command and obtain the following writer information. Then, you set the EnabledWriters registry value to the the Writer ID value and use the Windows Backup utility to back up the configuration data for Internet Information Services (IIS).

    Writer name: 'IIS Config Writer'

    Writer Id: {2a40fd15-dfca-4aa8-a654-1f8c654603f6}

    Writer Instance Id: {4f3e7efb-bfbe-4d81-8307-b0e306159874}

    State: [1] Stable

    Last error: No error


You can also create a DWORD value that has the BackupType name for the default backup type in the following path:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SPP

Note The registry value type is REG_DWORD. If the registry value is set to 0, the BackupType DWORD value is treated as the VSS_FULL backup type. Additionally, you use the VSS to perform a full backup, and the history of each file that is backed up is updated. If the registry value is set to a nonzero value, the BackupType DWORD value is treated as the VSS_COPY backup type. Additionally, the history of each file that is backed up is not updated.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.1.7600.20760172,54420-Jul-201004:57x86
Sxproxy.dll6.1.7600.1638531,74414-Jul-200901:16x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.1.7600.20760244,22420-Jul-201005:34x64
Sxproxy.dll6.1.7600.1638575,77614-Jul-200901:41x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about how to use VSS, visit the following Microsoft Developer Network (MSDN) website: For more information about AD LDS for Windows7, visit the following Microsoft website:For more information about the Wbadmin command, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,396
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameX86_2468344270a418bc2e23cc6d58603dd4_31bf3856ad364e35_6.1.7600.20760_none_3211311dadda0313.manifest
File versionNot applicable
File size696
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20760_none_e4b78dc827424628.manifest
File versionNot applicable
File size34,814
Date (UTC)20-Jul-2010
Time (UTC)07:44
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_2468344270a418bc2e23cc6d58603dd4_31bf3856ad364e35_6.1.7600.20760_none_8e2fcca166377449.manifest
File versionNot applicable
File size698
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameAmd64_4e6c63fac9245b7aa92382ffa121eb81_31bf3856ad364e35_6.1.7600.20760_none_be79901eb4c861bd.manifest
File versionNot applicable
File size1,040
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameAmd64_d79661d9b31dbee0f4a3afee4342c258_31bf3856ad364e35_6.1.7600.20760_none_b630cee16117ed20.manifest
File versionNot applicable
File size700
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameAmd64_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20760_none_40d6294bdf9fb75e.manifest
File versionNot applicable
File size34,818
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,804
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20760_none_e4b78dc827424628.manifest
File versionNot applicable
File size34,814
Date (UTC)20-Jul-2010
Time (UTC)07:42
PlatformNot applicable

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Keywords: kb, kbexpertiseinter, kbexpertiseadvanced, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2288055
Revision : 3
Created on : 4/10/2020
Published on : 4/10/2020
Exists online : False
Views : 234