Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"SCANREG /RESTORE" Command May Not Restore Registry


View products that this article applies to.

Symptoms

When you use the SCANREG /RESTORE command at a command prompt in MS-DOS mode to restore the registry, you may receive an error message stating that the registry was not restored.

↑ Back to the top


Cause

This behavior can occur if a third-party program (such as Norton Unerase) has the drive's disk access locked.

↑ Back to the top


Resolution

To work around this behavior:
  1. Restart the computer. Press and hold down the CTRL key until the Startup menu appears.
  2. Choose Step-by-Step Confirmation, and load only Himem.sys. Press N for all other prompts.
  3. Run the SCANREG /RESTORE command.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


More Information

Himem.sys is not required to run Scanreg.exe, but is required for Scandisk.exe and other tools that may be needed.

It may not be safe to unlock the drive.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

↑ Back to the top


Keywords: kb3rdparty, kbprb, kb

↑ Back to the top

Article Info
Article ID : 228779
Revision : 2
Created on : 8/1/2019
Published on : 8/1/2019
Exists online : False
Views : 237