Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A ticket request for a service principal name that includes an instance name of SQL Server fails on a domain controller that is running Windows Server 2003


Symptoms

Consider the following scenario:
  • You have two Windows Server 2003 forests, and the forest functional level (FFL) is Windows Server 2003.
  • You configure trust relationships between the two forests.
  • You register a service principal name (SPN) in one of the forests by using the following format: <service name>/<FQDN name of hosted server>: <the instance name of SQL server> . For example, you might use the following as a sample name:
    testservice/svcinst.testdomain.com:instance1
  • A user account sends a ticket request for the registered SPN in the other forest.
  • A Windows Server 2003 domain controller in the other forest handles the request.
In this scenario, the ticket request fails.

↑ Back to the top


Cause

This issue occurs because Windows Server 2003 domain controllers incorrectly assume that the string after the character ":" in an SPN is a port name.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your must be running Windows Server 2003 Service Pack 2 (SP2).For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Ntdsapi.dll5.2.3790.477773,72817-Sep-201015:18x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsapi.dll5.2.3790.4777133,12017-Sep-201012:57x64SP2SP2QFE
Wntdsapi.dll5.2.3790.477773,72817-Sep-201012:57x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsapi.dll5.2.3790.4777212,48017-Sep-201012:57IA-64SP2SP2QFE
Wntdsapi.dll5.2.3790.477773,72817-Sep-201012:57x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the service principal name, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2285736
Revision : 1
Created on : 1/7/2017
Published on : 10/13/2010
Exists online : False
Views : 222