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You receive Stop error message 0x000000CD or 0x00000019 on a computer that is running Windows Server 2003 when corrupted registry hive files are loaded


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • Some registry hive files are loaded on the computer. For example, some user registry hive files are loaded during the logon process.
In this scenario, the computer crashes. Additionally, you receive one of the following Stop error messages:
STOP 0x000000CD (parameter1 , 0 , parameter3 , parameter4)
The PAGE_FAULT_BEYOND_END_OF_ALLOCATION

0x00000019 ( parameter1 , parameter2 , parameter3 , parameter4 )
BAD_POOL_HEADER

Notes
  • This issue usually occurs when the user logs on to the computer or when the operating system loads registry hive files.
  • The parameters in this error message may vary, depending on the configuration of the computer.
  • Not all 0x000000CD or 0x00000019 Stop errors are caused by this issue.
  • Stop error 0x000000CD is applicable only when a special pool is enabled.

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Cause

This issue occurs because a pool corruption occurs in the operating system when a corrupted registry hive is loaded. This causes the system to crash and the stop error message that is mentioned in the "Symptoms" section to be generated.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.47712,500,09607-Sep-201020:50Not applicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.47712,310,65607-Sep-201019:46x86SPSP2QFE
Ntkrpamp.exe5.2.3790.47712,351,61607-Sep-201019:46Not applicableSPSP2QFE
Ntoskrnl.exe5.2.3790.47712,459,13607-Sep-201020:50x86SPSP2QFE
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.4354280,06409-Sep-201004:50x64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.47714,614,14409-Sep-201004:50x64SPSP2QFE
Ntoskrnl.exe5.2.3790.47714,540,92809-Sep-201004:50x64SPSP2QFE
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.44551,646,59209-Sep-201004:50IA-64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.47716,582,78409-Sep-201004:50IA-64SPSP2QFE
Wntdll.dll5.2.3790.4455775,16809-Sep-201004:50x86SP2SP2QFE\WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about registry, please visit the following Microsoft website:

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Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbfix, kbsurveynew, kbexpertiseinter, KB2280732

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Article Info
Article ID : 2280732
Revision : 4
Created on : 10/11/2010
Published on : 10/11/2010
Exists online : False
Views : 300