Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x00000050" Stop error occurs on a terminal server that is running Windows Server 2003 if a user mode printer driver is used in a terminal server session


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003 and that has the Terminal Service server role installed, you may receive an error message that resembles the following:
Stop 0x00000050 (parameter1 , parameter2 , parameter3 , parameter4 )
PAGE_FAULT_IN_NONPAGED_AREA

Notes
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x00000050" Stop error messages are caused by this issue.


This issue usually occurs in the following scenario:
  • You create a terminal server session to the terminal server.
  • You install a printer by using a user mode printer driver in the terminal server session.
  • You use an application to start a print job by using the user mode printer driver.
  • You try to close the application before the print job is finished.

↑ Back to the top


Cause

This issue occurs because of an error in the Win32k.sys driver.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47431,864,70414-Jul-201014:05x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47434,577,79215-Jul-201008:10x64
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.47435,595,13615-Jul-201008:10IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2279561

↑ Back to the top

Article Info
Article ID : 2279561
Revision : 5
Created on : 8/19/2010
Published on : 8/19/2010
Exists online : False
Views : 266