Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot access an MPIO-controlled storage device in Windows Server 2008 R2 after you send the "IOCTL_MPIO_PASS_THROUGH_PATH_DIRECT" control code that has an invalid MPIO path ID


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2.
  • You connect a storage device that is controlled by Microsoft Multipath I/O (MPIO) to the computer.
  • You use a Microsoft Device Specific Module (DSM) for MPIO.
  • You send the IOCTL_MPIO_PASS_THROUGH_PATH_DIRECT control code that has an invalid MPIO path ID to the storage device.
In this scenario, any later attempts to access the storage device fail. Therefore, the application or operating system that tries to access the storage device stops responding, or it encounters other exceptions.

Note To recover from this issue, you have to restart the computer.

↑ Back to the top


Cause

This issue occurs because the MPIO driver handles the IOCTL_MPIO_PASS_THROUGH_PATH_DIRECT control code that has an invalid MPIO path ID incorrectly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7600.20881156,54415-Jan-201106:26x64
Mpio.sys6.1.7601.21642156,54415-Jan-201106:29x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7600.20881351,61615-Jan-201105:24IA-64
Mpio.sys6.1.7601.21642351,10415-Jan-201105:19IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7600.20881_none_79ad717dc226751f.manifest
File versionNot Applicable
File size2,073
Date (UTC)15-Jan-2011
Time (UTC)07:00
PlatformNot Applicable
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7601.21642_none_7bc00e7dbf2b8a9e.manifest
File versionNot Applicable
File size2,073
Date (UTC)15-Jan-2011
Time (UTC)07:02
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,170
Date (UTC)15-Jan-2011
Time (UTC)16:55
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7600.20881_none_1d9079f009c70ce5.manifest
File versionNot Applicable
File size2,071
Date (UTC)15-Jan-2011
Time (UTC)06:50
PlatformNot Applicable
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7601.21642_none_1fa316f006cc2264.manifest
File versionNot Applicable
File size2,071
Date (UTC)15-Jan-2011
Time (UTC)06:59
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,933
Date (UTC)15-Jan-2011
Time (UTC)16:55
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2277904
Revision : 1
Created on : 1/7/2017
Published on : 2/10/2011
Exists online : False
Views : 246