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Different reference periods are used in an Intrastat journal when you process Intrastat reporting of corrective entry in the Italian version of Microsoft Dynamics NAV


View products that this article applies to.

Microsoft Business Solutions-Navision 4.0 and Microsoft Navision 4.0 are now part of Microsoft Dynamics NAV 4.0. All references to Microsoft Business Solutions-Navision or to Microsoft Navision 4.0 relate to Microsoft Dynamics NAV.

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This article applies to Microsoft Dynamics NAV for the Italian (it) language locale.

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Symptoms

When you process Intrastat reporting of corrective entry in the Italian version of Microsoft Dynamics NAV, different reference periods are used in an Intrastat journal. This problem occurs in the following products:
  • The Italian version of Microsoft Dynamics NAV 2009 Service Pack 1
  • The Italian version of Microsoft Dynamics NAV 5.0 Service Pack 1
  • The Italian version of Microsoft Dynamics NAV 4.0 Service Pack 3

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Cause

This problem occurs because the Reference Period field and the Corrected Intrastat Report No field are mandatory when you create an Intrastat file for an Intrastat batch of corrective entry. However, one of the fields should not be required. In the same Intrastat batch, different Reference Period values cannot be used. The different Correted Intrastat Report No values can refer to different periods. Therefore, the Reference Period value is not used to fill in the period in the file. Instead, the statistics period of the batch name that is inserted as the Corrected Intrastat Report No value is used.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV 2009 service pack or the next Microsoft Dynamics NAV version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


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Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:
  • The Modify permission for the object that you will be changing.
  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.


Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.
To resolve this problem, follow these steps:
  1. Change the code in the Corrected Intrastat Report No. - OnValidate trigger in the Intrastat Jnl. Line table (263) as follows:
    Existing code
    ...
    IF "Corrected Intrastat Report No." <> '' THEN BEGIN
    IntrastatJnlBatch.CheckEUServAndCorrection("Journal Template Name","Journal Batch Name",FALSE,TRUE);
    SetIntrastatJnlBatchFilters(IntrastatJnlBatch2);
    IntrastatJnlBatch2.SETRANGE(Name,"Corrected Intrastat Report No.");

    // Delete the following lines.
    IF IntrastatJnlBatch2.ISEMPTY THEN
    FIELDERROR("Corrected Intrastat Report No.");
    // End of the lines.

    END;
    ...
    Replacement code
    ...
    IF "Corrected Intrastat Report No." <> '' THEN BEGIN
    IntrastatJnlBatch.CheckEUServAndCorrection("Journal Template Name","Journal Batch Name",FALSE,TRUE);
    SetIntrastatJnlBatchFilters(IntrastatJnlBatch2);
    IntrastatJnlBatch2.SETRANGE(Name,"Corrected Intrastat Report No.");

    // Add the following lines.
    IF NOT IntrastatJnlBatch2.FINDFIRST THEN
    FIELDERROR("Corrected Intrastat Report No.")
    ELSE
    VALIDATE("Reference Period",IntrastatJnlBatch2."Statistics Period");
    // End of the lines.

    END;
    ...
  2. Set the DelayedInsert property of the Intrastat Journa form (311) to Yes.
  3. Set the Editable property of the Reference Period field in the Intrastat Journa form (311) to No.
  4. Change the code in the Intrastat Jnl. Line - OnAfterGetRecord trigger in the Intrastat - Make Disk Tax Auth report (593) as follows:
    Existing code
    ...
    TESTFIELD("Transaction Specification");
    CheckCorrectiveStatPeriod;

    // Delete the following lines.
    IF (OldReferencePeriod <> '') AND ("Reference Period" <> OldReferencePeriod) THEN
    ERROR(Text1130005);
    // End of the lines.

    "Intra - form Buffer".TRANSFERFIELDS("Intrastat Jnl. Line");
    ...
    Replacement code
    ...
    TESTFIELD("Transaction Specification");
    CheckCorrectiveStatPeriod;
    "Intra - form Buffer".TRANSFERFIELDS("Intrastat Jnl. Line");
    ...

Prerequisites

You must have one of the following products installed to apply this hotfix:
  • The Italian version of Microsoft Dynamics NAV 2009 Service Pack 1
  • The Italian version of Microsoft Dynamics NAV 5.0 Service Pack 1
  • The Italian version of Microsoft Dynamics NAV 4.0 Service Pack 3

Removal information

You cannot remove this hotfix.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: kbmbsdatabaseandplatforms, kbsurveynew, kbnotautohotfix, kbmbscodefix, kbqfe, kbmbsquickpub, kbnoloc, kbmbspartner, kb, kbmbsmigrate

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Article Info
Article ID : 2275766
Revision : 2
Created on : 9/25/2018
Published on : 9/25/2018
Exists online : False
Views : 251