Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Quantity mismatch between Lot transaction and inventory transaction records" error message in Microsoft Dynamics SL


Symptoms

Consider the following scenario in Order Management and Inventory in Microsoft Dynamics SL:
  • You have quantity available and quantity on hand in multiple warehouse bin locations at the same inventory site for an inventory ID that is not lot tracked or serial tracked.
  • You create a shipper in Order Management for the inventory ID.
  • You confirm shipment for the shipper on the Shipment Confirmation (40.117.00) screen.
  • You print the Sales Journal (40.690.00) report that contains the shipper.
  • You release the resulting inventory issues batch.
In this scenario, the following error message is logged in the event log:
Quantity mismatch between Lot transaction and inventory transaction records for line '%' in batch '%' inventory item '%. The batch will not be released

You expect the batch to be released correctly.

↑ Back to the top


Cause

This problem occurs for the following reasons:
  • The inventory issues batch is created with missing records in the Intran table in the database.
  • Records are created unexpectedly in the Lotsert table in the database for an inventory ID that is not lot tracked or serial tracked.

↑ Back to the top


Resolution

Hotfix information for Microsoft Dynamics SL

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics SL Service Pack that contains this hotfix as specified in the "Status" section in this article.

To resolve this problem, click the "View and request hotfix downloads" link at the top of this article to obtain the hotfix.

Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft website:

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.


Microsoft Dynamics SL 7.0 Service Pack 3 (SP3)
Changed filesDateFile version
4011000.exe 07-Jul 20107.04.40707.00
4011700.exe07-Jul 20107.04.40707.00
Bug21642OM.sql07-Jul 2010

Microsoft Dynamics SL 7.0 Feature Pack 1 (FP1)
Changed filesDateFile version
4010000.exe 25-Jun 20107.03.40625
4011000.exe25-Jun 20107.03.40625
4011700.exe25-Jun 20107.03.40625
4040000.exe25-Jun 20107.03.40625
4069002.exe25-Jun 20107.03.40625
4099000.exe25-Jun 20107.03.40625
Bug21644OM.sql02-Jul 2010
Messages.msg02-Jul 2010

Installation information

Install this hotfix by following the installation instructions that are included in the hotfix download.

Prerequisites

For information about the prerequisites for this hotfix, refer to the installation instructions that are included in the hotfix download.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

You cannot remove this hotfix.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was reported as issue number 21642 and 21644.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbsolomon, kbhotfixserver, kbqfe, kbmbsmigrate, kbmbspartner, kbtshoot, kbbug, kb, kbexpertisebeginner, kbexpertiseinter, kbautohotfix, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2275103
Revision : 3
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 121