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You experience delays of up to 60 seconds when you use a multiprocessor computer that is running Windows 7 or Windows Server 2008 R2 to read or write lots of data to a storage device that is connected by using a 1394 port


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a multiprocessor computer that is running Windows 7 or Windows Server 2008 R2.
  • A storage device such as a hard disk is connected to the computer by using a 1394 port.
  • You perform many read or write operations to the storage device.
In this scenario, you may experience data access delays of up to 60 seconds.

For example, you copy a 4 GB file to the storage device by using Windows Explorer. In this example, the copying process stops responding intermittently for up to 60 seconds.

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Cause

The issue occurs because of a race condition that occurs when an I/O request to the storage device is queued on a multiprocessor computer. When the race condition occurs, the request is never sent to the device. After 60 seconds, the request is retried.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows 7.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important for maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Sbp2port.sys6.1.7600.2075085,38408-Jul-201005:05x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Sbp2port.sys6.1.7600.20750103,81608-Jul-201005:51x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Sbp2port.sys6.1.7600.20750282,50408-Jul-201004:39IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File namePackage_1_for_kb2275019~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,832
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_2_for_kb2275019~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,832
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_3_for_kb2275019~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,831
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_for_kb2275019_rtm~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size2,199
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File nameX86_sbp2.inf_31bf3856ad364e35_6.1.7600.20750_none_45b40bdf70809398.manifest
File versionNot applicable
File size2,077
Date (UTC)08-Jul-2010
Time (UTC)05:36
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_sbp2.inf_31bf3856ad364e35_6.1.7600.20750_none_a1d2a76328de04ce.manifest
File versionNot applicable
File size2,081
Date (UTC)08-Jul-2010
Time (UTC)06:30
PlatformNot applicable
File namePackage_1_for_kb2275019~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,842
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_2_for_kb2275019~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,842
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_3_for_kb2275019~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,841
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_for_kb2275019_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size2,213
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_sbp2.inf_31bf3856ad364e35_6.1.7600.20750_none_45b5afd5707e9c94.manifest
File versionNot applicable
File size2,079
Date (UTC)08-Jul-2010
Time (UTC)06:30
PlatformNot applicable
File namePackage_1_for_kb2275019~31bf3856ad364e35~ia64~~6.1.1.0.mum
File versionNot applicable
File size1,837
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable
File namePackage_for_kb2275019_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mum
File versionNot applicable
File size1,450
Date (UTC)08-Jul-2010
Time (UTC)07:40
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2275019
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 209