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An application that uses DES encryption for Kerberos authentication cannot run on a Windows XP-based client computer in a Windows Server 2008 domain


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a computer that is running Windows Server 2008 R2 as a domain controller in a domain.
  • You enable Data Encryption Standard (DES) encryption for Kerberos authentication on the domain controller.
  • You configure the domain functional level to Windows Server 2008 in the domain.
  • You join a Windows XP-based client computer to the domain.
  • You run an application on the Windows XP-based client computer. The application uses only DES encryption for Kerberos authentication.
In this scenario, Kerberos authentication fails. Therefore, the application cannot run.

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Cause

This problem occurs because of an error in the Kerberos Key Distribution Center (KDC) service on the Windows Server 2008 R2-based domain controller. By default, the KDC service selects the RC4 algorithm as the encryption type in the ticket-granting ticket (TGT) delegation if both the Kerberos server side and the Kerberos client side support the RC4 algorithm. This problem occurs even if DES encryption is configured as the preferred encryption method.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 with the Active Directory Domain Services role installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important for maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll6.1.7600.20756429,56816-Jul-201010:47x64
Kdcsvc.mofNot applicable5,30010-Jun-200921:01Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_d4d79987f90c80cc0e20a7efbb067f27_31bf3856ad364e35_6.1.7600.20756_none_61d52da6328f350d.manifest
File versionNot applicable
File size724
Date (UTC)16-Jul-2010
Time (UTC)21:07
PlatformNot applicable
File nameAmd64_microsoft-windows-k..distribution-center_31bf3856ad364e35_6.1.7600.20756_none_e857cc82c6f64656.manifest
File versionNot applicable
File size35,825
Date (UTC)16-Jul-2010
Time (UTC)11:44
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,706
Date (UTC)16-Jul-2010
Time (UTC)21:07
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2274102
Revision : 2
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 249