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Error message when you install SQL Server 2008 R2 before you run the PreRequisiteInstaller.exe tool


Symptoms

Consider the following scenario:
  • You install Microsoft SQL Server 2008 R2 (including SQL Server Database Engine and SQL Server Analysis Service). 
  • You run the PreRequisitesInstaller.exe tool from the Microsoft SharePoint Server 2010 media.
  • You install the SharePoint Server 2010 Enterprise Edition. Then, the SQL Server 2008 R2 installer is run again.
  • You continue the installation and then you reach a dialog that needs the Analysis Services SharePoint Integration feature to be installed.
In this scenario, , the installation fails and you receive the following error message: 
Could not load assembly ‘Microsoft.AnalysisServices.SharePoint.Integration.dll’

Note
This issue occurs in both new server installations and existing farm installations.

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Cause

This issue occurs because the installation order causes a conflict with one of the SQL Server components. The component references the Microsoft.AnalysisServices.SharePoint.Integration.dll assembly before the component is installed in the computer. When the component is installed, a conflict occurs and the system caches the error even though the file does exist.

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Workaround

To work around this issue, follow these methods:


Note Before you follow any of these methods, save the following code to a file that is named Setup100.exe.config.
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<disableCachingBindingFailures enabled="1" />
</runtime>
</configuration>

Method 1

If you have the PowerPivot for SharePoint components installed in your computer, follow these steps:
  1. Uninstall the PowerPivot instance of Analysis Services. This action also uninstalls PowerPivot for SharePoint components.
  2. Restart your computer.
  3. Run the scripts to re-enable the PremiumSite feature. For more information about how to enable the PremiumSite feature, click the following link to view the article in the Microsoft Knowledge Base:
    2261512 Post-Uninstall Premium Site Feature repair

  4. Restart your computer.
  5. Copy the Setup100.exe.config file to the following path:
    %ProgramFiles%\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2\x64
  6. Reinstall the PowerPivot for SharePoint components.

Method 2

If you do not have the PowerPivot for SharePoint components installed in your computer, follow these steps:
  1. Verify that the following directory exists in your computer:
    %ProgramFiles%\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2\x64
  2. If the directory exists, follow these steps:
    1. Copy the setup100.exe.config file to the directory.
    2. Install PowerPivot for SharePoint component.
  3. If the directory does not exist, follow these steps:
    1. Run the installation file until you reach the Setup Support Files window. Then, click Install.
    2. When the installation of the support files is completed, click Cancel. The directory should now exist in your computer.
    3. Copy the Setup100.exe.config file to the directory.
    4. Restart your computer.
    5. Rerun the installation file.

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Keywords: kbsurveynew, kbexpertiseadvanced, kbprb, kb

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Article Info
Article ID : 2261507
Revision : 1
Created on : 1/7/2017
Published on : 8/9/2010
Exists online : False
Views : 101