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You cannot access shared files or shared printers from a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario. You have a computer that is running Windows Vista or Windows Server 2008. From this computer, you try to access shared files or shared printers that are hosted on a remote computer. However, the access operation becomes unresponsive.

Notes
  • When this issue occurs, you cannot access shared files or shared printers that are hosted on any remote computers.
  • The collected network trace indicates that the Server Message Block (SMB) Version 2 protocol is used to access shared files or shared printers.

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Cause

This issue occurs because of a problem in the Redirected Drive Buffering SubSystem (Rdbss.sys) driver. This driver holds some resources when it waits for a response from the cache manager, and one of those resources is required for the cache manager to complete its task. Therefore, a deadlock situation occurs, and the access operation becomes unresponsive. 

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22448225,79216-Jul-201013:35x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22448289,28016-Jul-201013:47x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22448680,44816-Jul-201013:20IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,078
Date (UTC)16-Jul-2010
Time (UTC)23:35
PlatformNot applicable
File nameX86_d5d22d6c450b9758f62ec73d53081758_31bf3856ad364e35_6.0.6002.22448_none_01f4ed7bd743a29a.manifest
File versionNot applicable
File size693
Date (UTC)16-Jul-2010
Time (UTC)23:35
PlatformNot applicable
File nameX86_microsoft-windows-rdbss_31bf3856ad364e35_6.0.6002.22448_none_5c21b48377c68de8.manifest
File versionNot applicable
File size6,856
Date (UTC)16-Jul-2010
Time (UTC)17:49
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_d24f51264039dec9671fbfbd7d8a9588_31bf3856ad364e35_6.0.6002.22448_none_de1b520c4f4bd310.manifest
File versionNot applicable
File size697
Date (UTC)16-Jul-2010
Time (UTC)23:36
PlatformNot applicable
File nameAmd64_microsoft-windows-rdbss_31bf3856ad364e35_6.0.6002.22448_none_b84050073023ff1e.manifest
File versionNot applicable
File size7,113
Date (UTC)16-Jul-2010
Time (UTC)18:16
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,102
Date (UTC)16-Jul-2010
Time (UTC)23:36
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_f74c6eeada668d1254fedd92e686b6d6_31bf3856ad364e35_6.0.6002.22448_none_e65424ca65b7e3d0.manifest
File versionNot applicable
File size695
Date (UTC)16-Jul-2010
Time (UTC)23:35
PlatformNot applicable
File nameIa64_microsoft-windows-rdbss_31bf3856ad364e35_6.0.6002.22448_none_5c23587977c496e4.manifest
File versionNot applicable
File size7,107
Date (UTC)16-Jul-2010
Time (UTC)16:03
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,255
Date (UTC)16-Jul-2010
Time (UTC)23:35
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kb

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Article Info
Article ID : 2251177
Revision : 3
Created on : 9/28/2018
Published on : 9/28/2018
Exists online : False
Views : 222