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SharePoint Workspace syncs only one of your Office 365 team sites


Symptoms

Consider this scenario:

You have a business that uses SharePoint Online, and you do work for a charitable organization that also uses SharePoint Online. You access these SharePoint Online sites using two Office 365 accounts. At different times, you use the site action Sync to SharePoint Workspace on each site to create a workspace from that site in SharePoint Workspace 2010.

However, you notice that only one workspace synchronizes at any given time, and you receive sync errors for spaces associated with the other account. The workspace associated with your current Office 365 login syncs without error.  If you log out with your current Office 365 account, restart your browser, and then log in with the other account, the workspace that synchronizes successfully will change to match the active account.

If you have a browser window open and attempt a manual sync on the workspace that is not synchronizing, SharePoint Workspace does not prompt for credentials and the sync fails. If you close the browser window and then attempt a manual sync, SharePoint Workspace does prompt for credentials.
This behavior is different from using SharePoint workspaces with enterprise servers that use Windows authentication, where you can have workspaces that are individually associated with different domain accounts. 

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Cause

There are two details that contribute to this limitation:

  • Office 365 uses Forms-Based Authentication
  • Office 365 uses Windows Live credentials, and Internet Explorer can only store authentication information for one set of these credentials at a time.

SharePoint Workspace uses Internet Explorer to support Forms-Based Authentication . If you have a web browser open, SharePoint Workspace uses the authentication information stored by the browser when it attempts to access the Office 365 site. If this information does not match the site, authentication will fail.

Because the browser can store only one authentication information for one Office 365 login, when two of these logins are associated with workspace, both cannot be authenticated.

If you do not have a web browser open, automatic sync will fail silently. However, manual sync will prompt you for authentication information.

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More Information

 

You can manually synchronize each workspace with Internet Explorer closed. Follow these steps:

  1. In the first workspace, under Sync, click Sync Workspace. Provide your credentials when prompted.
  2. In the second workspace, under Sync, click Sync Workspace.
  3. In the error window, click sign in as a different user, and provide your credentials.

One way to avoid this problem is to maintain separate installations of SharePoint Workspace on different computers, and dedicate each computer to a specific Office 365 account.

In some environments, you can also associate the two Office 365 accounts, but then the accounts have access to each other’s resources in other applications as well.


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Article Info
Article ID : 2231936
Revision : 1
Created on : 1/8/2017
Published on : 12/21/2011
Exists online : False
Views : 183