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The MID_UNRESOLVED error occurs when the "NspiResolveNames" method is used to search using a string that begins with symbol character in a Windows Server 2008 R2-based Domain Controller


View products that this article applies to.

Symptoms

Consider the following scenario:�
  • You install the Active Directory Domain Services (AD DS) role on a computer that is running Windows Server 2008 R2.�
  • You configure the computer as a global catalog server in the domain.
  • Microsoft Exchange Server 2007 or newer is installed on another member server in this domain.
  • Microsoft Outlook 2007 or newer is used by the client.
  • The problem may happen in the same way by other applications that�use NspiResolveNames.

In this setup, you may encounter the following problems with these attributes:

Display Name:
  • You create a user account that has an opening parenthesis "(" character for the first character in the display name.
  • You type the display name in the "To" or "CC" field of a Microsoft Office Outlook 2007 message and try to resolve the name.
  • Microsoft Office Outlook will start an ANR search and send it to th3e Windows SErver 2008 R2 DC.

Phone, Pager or Fax Numbers:
  • You extend the Advanced Search form used by Outlook to contain one or more phone number attributes.
  • Your user accounts�have phone numbers with the plus "+" character for the first character in the phone numbers.
  • The user opens the contact search by clicking on the "To..." or "CC..." button of the compose Email window. From there, he clicks the "Advanced Find" link.
  • In the form, you select your field for the phone number and you type the start of a phone number including "+" and start the search.
  • Microsoft Office Outlook will start a search using the field you entered data in as a "starts with" search.
  • When you have added the attribute to the set of attributes for an ANR search, you can start the search like in the "Display Name" scenario.

In all scenarios, Microsoft Office Outlook or your application cannot resolve the name or phone number to a contact in the database.

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Cause


An application or service calls the�NspiResolveNames�method to perform a search in the domain. This method may perform an ANR search or regular search by using a string that begins with symbol, for example an opening parenthesis�"("�or�plus�"+"�character. The�NspiResolveNames�method fails with the MID_UNRESOLVED error code in this case.

The problems can occur with any symbol-type characters, such as the minus, multiply or division symbols, or separator characters such as comma, semicolon or colon. The common theme is that they are used as the first character of the string to search for, and the same string is in the Ative Directory database. In these cases, the filter evaluation skips the symbol characters in both string and filter and thus does not return the start of the string as the match which causes the filter match to fail.

This string compare behavior is used since�the result set should be sorted in the client locale and the call through the Name Service Provider Interface (NSPI) always asks for this sorting to happen. So the locale settings are used on all string compares for the request.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 and have the Active Directory Domain Service role installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately�in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.mofNot applicable227,76510-Jun-200920:34Not applicable
Ntdsai.dll6.1.7600.207312,721,28011-Jun-201005:49x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
You can change the dialogs used by Outlook through the�"Details Templates Editor" in the Microsoft Exchange Management Console. The link below describes the steps for the user details template, but it works the same way for the "Search Dialog":

http://technet.microsoft.com/en-us/library/bb124494(EXCHG.80).aspx

For more information about the NspiResolveNames method, visit the following Microsoft website:

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_48cd2e7a792df0a4ffff4ed77a926b09_31bf3856ad364e35_6.1.7600.20731_none_188e0c8d365acad7.manifest
File versionNot applicable
File size716
Date (UTC)11-Jun-2010
Time (UTC)18:36
PlatformNot applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7600.20731_none_4d76e484ebcc7174.manifest
File versionNot applicable
File size3,531
Date (UTC)11-Jun-2010
Time (UTC)08:37
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,356
Date (UTC)11-Jun-2010
Time (UTC)18:36
PlatformNot applicable

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Keywords: KB2225490, kbexpertiseadvanced, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2225490
Revision : 4
Created on : 8/30/2010
Published on : 8/30/2010
Exists online : False
Views : 303