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XFOR: Internet Mail Service Sends MIME Plain Text as Both HTML and Plain Text


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This article was previously published under Q222508
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

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Symptoms

When you send plain text from an Outlook client that has an Exchange Server as the backend with the Internet Mail Service configured to send plain text or HTML, the Internet Mail Service overrides the user's choice, and sends both plain text and HTML. When MCI Mail or other plain text mail readers receive a message as MIME/multipart/alternative, the recipient gets one e-mail message with plain text at the top followed by the same message embedded in HTML tags.

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Cause

The Internet Mail Service doesn't get the sender's option in the message. As a result it, sends both the plain text and the HTML.

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Resolution

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014� XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:

Component: Internet Mail Service

Collapse this tableExpand this table
File nameVersion
Gapi32.dll5.5.2571.0
Imcmsg.dll5.5.2571.0
Mdbmsg.dll5.5.2571.0
Msexcimc.exe5.5.2571.0
Store.exe5.5.2571.0

This hotfix has been posted to the following Internet location as Psp2imca.zip and Psp2imci.zip:

More Information

In addition to the new files noted above and the client-side updates, the following registry changes must be made to enable this functionality. To make the registry changes, perform the following steps:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Stop the Microsoft Exchange Internet Mail Service and the Microsoft Exchange Information Store service.
  2. Apply the fixed files noted above.
  3. Start Registry Editor (Regedt32.exe)
  4. Go to the following location in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIMC\Parameters
  5. On the Edit menu, click Add Value.
    Value Name: SendPlainTextAsIs
    Data Type: REG_DWORD
    Value: 0x0, 0x1
    Default: 0x0 (not in registry by default)
    After this key is set, all plain text mail generated by Outlook will be sent out as plain text without any HTML tags.

  6. Click OK, and quit Registry Editor.
  7. Restart the Microsoft Exchange Information Store service and Microsoft Exchange Internet Mail Service.

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

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Keywords: KB222508, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver

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Article Info
Article ID : 222508
Revision : 5
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 282