Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Meetings are not processed or messages are automatically deleted with a non-default AutomateProcessing parameter value


View products that this article applies to.

Symptoms

When you receive a meeting request in an Exchange 2007 (or later) environment, the meeting does not appear automatically on your calendar in a�tentative state.

↑ Back to the top


Cause

This problem occurs under either of the following situations.
  • The processing of meeting requests has been disabled for your mailbox in the Exchange Calendar Assistant

    In this situation, if you use the following cmdlet in the Exchange Management Shell, you will see the value of the AutomateProcessing parameter is set to None.

    • Exchange 2010

      Get-CalendarProcessing <alias> |FL AutomateProcessing
    • Exchange 2007

      Get-MailboxCalendarSettings <alias> |FL AutomateProcessing
NOTE: In some scenarios for user mailboxes, the AutomateProcessing parameter has been seen to have a value of AutoAccept, even though the AutoAccept value can only be applied to Resource mailboxes. In this configuration, there have been reports of automatic deletion of e-mail messages sent to the mailbox. If the output from the above cmdlet shows the AutomateProcessing parameter value is set to AutoAccept on a user mailbox, use the solution in the Resolution section of this article to reset the AutomateProcessing parameter back to the default value (AutoUpdate).
  • The AddNewRequestsTentatively parameter is set to $False

    In this situation, if you use the following cmdlet in the Exchange Management Shell, you will see the value of the AddNewRequestsTentatively parameter.
    • Exchange 2010

      Get-CalendarProcessing <alias> |FL AddNewRequestsTentatively
    • Exchange 2007

      Get-MailboxCalendarSettings <alias> |FL AddNewRequestsTentatively

↑ Back to the top


Resolution

To resolve this problem, use the appropriate cmdlet listed below, depending on the results of the cmdlets provided in the Cause section.
  • Change the value of the�AutomateProcessing parameter to AutoUpdate.
    • Exchange 2010

      Set-CalendarProcessing -identity alias -AutomateProcessing AutoUpdate
    • Exchange 2007

      Set-MailboxCalendarSettings -identity alias -AutomateProcessing AutoUpdate
    Note, in the above example cmdlets, replace alias with the appropriate identity value for the mailbox.

  • Change the value of the AddNewRequestsTentatively parameter to $True.
    • Exchange 2010

      Set-CalendarProcessing -identity alias -AddNewRequestsTentatively $True
    • Exchange 2007

      Set-MailboxCalendarSettings -identity alias -AddNewRequestsTentatively $True
    Note, in the above example cmdlets, replace alias with the appropriate identity value for the mailbox.

↑ Back to the top


More information

By default, in an Exchange 2007 (or later) environment, meeting requests are automatically marked as Tentative by the Exchange Calendar Assistant.�However, if you disable the sniffer process in Outlook 2007 or later, the AutomateProcessing parameter for the user's mailbox is changed from�AutoUpdate to None.

The following setting in Outlook controls the sniffer feature in Outlook.

  • Outlook 2010

    Automatically process meeting requests and responses to meeting requests and polls



    To get to the Automatically process meeting requests and responses to meeting requests and polls setting, use the following steps:
    1. On the File tab, click Options.
    2. On the Mail section, scroll down to Tracking.

  • Outlook 2007

    Process requests and responses on arrival



    To get to the Process requests and responses on arrival setting, use the following steps:
    1. On the Tools menu, click Options.
    2. On the Preferences tab, click E-mail Options.
    3. Then, click Tracking Options.

↑ Back to the top


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

↑ Back to the top


Keywords: KB2212449

↑ Back to the top

Article Info
Article ID : 2212449
Revision : 8
Created on : 5/25/2012
Published on : 5/25/2012
Exists online : False
Views : 534