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You receive "No results were found" when using the CRM 4.0 E-mail Router


Symptoms

When you do a test access from the Email Router you get the following error message:

Name: CRM User
Incoming Status: Failure - No results were found.

 

The event viewer error is as follows:

#26090 - An error occurred while opening mailbox user@domain.com. Microsoft.Crm.Tools.Email.Providers.EmailException: No results were found.
at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.IsCurrentUser()
at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.GetService()
at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.OpenMailbox()
at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.InitExchangeConnector()
at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()

 

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Cause

The mailbox is hidden from the Exchange address lists

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Resolution

1. Open Exchange Management console
2. Expand Recipient Configuration
3. Click on Mailbox
4. Right Click on the CRM User and select properties
5. On the General Tab make sure “Hide from Exchange address lists” is NOTchecked.

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Article Info
Article ID : 2190890
Revision : 1
Created on : 1/8/2017
Published on : 6/12/2010
Exists online : False
Views : 110