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A write operation to a volume is slower than usual in Windows Server 2008 or in Windows 7 after you create a snapshot of the volume


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2 or Windows 7.
  • You create a Volume Shadow Copy Service (VSS) snapshot of a volume.
  • You write a new file to the volume.
In this scenario, the write operation is slower than usual. For example, the write operation requires two times as much time to finish compared to the usual time that is required.

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Cause

This issue occurs because the Volume Shadow Copy driver (Volsnap.sys) calculates the boundary of the free disk space that has copy-on-write protection incorrectly.

When the NTFS driver tries to write a new file, the driver queries the Volume Shadow Copy driver (Volsnap.sys) to find the free disk space that does not have the copy-on-write protection. However, the NTFS driver incorrectly writes the new file to an area that has the copy-on-write protection. For each write operation to an area that has the copy-on-write protection, there is an additional read operation and an additional write operation. Therefore, the performance of the write operation decreases.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows 7
  • Windows Server 2008 R2

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimeHashesPlatform
Volsnap.sys6.1.7600.20747245,12002-Jul-201006:25MD5: 63CF6629FF8FA5C5DA02611258AF4348
SHA1: D77639B2AAC10F023A946874A675415AAFE1E438
x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7600.20747295,29602-Jul-201007:20x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7600.20747676,23202-Jul-201005:51IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File namePackage_1_for_kb2155024~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,838
Date (UTC)02-Jul-2010
Time (UTC)09:33
SHA-1 hashNot applicable
MD5 hashNot applicable
File namePackage_2_for_kb2155024~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,838
Date (UTC)02-Jul-2010
Time (UTC)09:33
SHA-1 hashNot applicable
MD5 hashNot applicable
File namePackage_3_for_kb2155024~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size1,837
Date (UTC)02-Jul-2010
Time (UTC)09:33
SHA-1 hashNot applicable
MD5 hashNot applicable
File namePackage_for_kb2155024_rtm~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot applicable
File size2,199
Date (UTC)02-Jul-2010
Time (UTC)09:33
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameX86_volume.inf_31bf3856ad364e35_6.1.7600.20747_none_1643f0657663ea67.manifest
File versionNot applicable
File size2,083
Date (UTC)02-Jul-2010
Time (UTC)06:50
SHA-1 hashNot applicable
MD5 hashNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_volume.inf_31bf3856ad364e35_6.1.7600.20747_none_72628be92ec15b9d.manifest
File versionNot Applicable
File size2,087
Date (UTC)02-Jul-2010
Time (UTC)07:44
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,658
Date (UTC)02-Jul-2010
Time (UTC)09:33
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_volume.inf_31bf3856ad364e35_6.1.7600.20747_none_1645945b7661f363.manifest
File versionNot Applicable
File size2,085
Date (UTC)02-Jul-2010
Time (UTC)07:40
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,451
Date (UTC)02-Jul-2010
Time (UTC)09:33
PlatformNot Applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 2155024
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 150