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FIX: "0x0000009E" Stop error when you host Hyper-V virtual machines in a Windows Server 2008 R2-based failover cluster


View products that this article applies to.

Symptoms

When you host Hyper-V virtual machines in a Windows Server 2008 R2-based failover cluster, you may receive a Stop error message that resembles the following:
0x0000009E ( parameter1 , parameter2 , parameter3 , parameter4 )
USER_MODE_HEALTH_MONITOR

When this problem occurs, the applications that are running on the virtual machines do not work.

Notes
  • The parameters in the Stop error message may vary, depending on the configuration of the computer.
  • Not all "0x0000009E" Stop errors are caused by this problem.

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Cause

This problem occurs because of a race condition between a thread that is freeing the kernel stack and another thread that is allocating memory. Specifically, the freed kernel stack can be put into a queue so that the worker thread will be picked up. If a memory allocation attempt occurs before the worker thread cleans up the kernel stack memory, this problem occurs.

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Resolution

Hotfix file information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix package.

File information

The English (United States) version of this hotfix uses a Microsoft Windows Installer package to install the hotfix. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all x64-based versions of�Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.207385,474,18419-Jun-201007:05x64
Ntkrnlpa.exe6.1.7600.207383,964,80019-Jun-201006:37Not applicable
Ntoskrnl.exe6.1.7600.207383,909,51219-Jun-201006:37Not applicable
For all IA-64-based versions of�Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.2073811,129,21619-Jun-201006:12IA-64
Ntkrnlpa.exe6.1.7600.207383,964,80019-Jun-201006:37Not applicable
Ntoskrnl.exe6.1.7600.207383,909,51219-Jun-201006:37Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to set up Hyper-V and the Failover Clustering feature, visit the following Microsoft TechNet website:

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Keywords: kbqfe, kbfix, kbexpertiseinter, kbprb, kbsurveynew, kbautohotfix, KB2135160

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Article Info
Article ID : 2135160
Revision : 3
Created on : 2/14/2013
Published on : 2/14/2013
Exists online : False
Views : 329