Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Virtual machines in a VDI environment are not rolled back as expected if the disconnected Remote Desktop connections on the virtual machines are stopped by Group Policy


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You deploy a Microsoft Virtual Desktop Infrastructure (VDI) environment in the network.
  • You enable the Remote Desktop Virtualization Host (RD Virtualization Host) role service on the Windows Server 2008 R2-based computers.
  • You configure rollback images for all virtual machines in the VDI environment.
  • You enable the following Group Policy settings on the virtual machines in the VDI environment:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits\Set time limit for disconnected sessions

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits\Terminate session when time limits are reached
  • There is only a disconnected Remote Desktop connection on a virtual machine.
In this scenario, the virtual machine is not rolled back as expected when the disconnected Remote Desktop connection is stopped by the configured Group Policy settings.

Additionally, if you run the qwinsta /vm command on the computer that hosts the virtual machine, the result indicates that the disconnected session still exists even if it is stopped.

↑ Back to the top


Cause

This problem occurs because the virtual machine host incorrectly ignores the user logoff event when the logoff occurs after the disconnection. Because the virtual machine host does not process the event, the virtual machine is still kept in the disconnected state and cannot roll back.

↑ Back to the top


Resolution

To resolve the problem, install the following hotfix on the affected Windows Server 2008 R2-based server that has the RD Virtualization Host role service installed.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 that has the RD Virtualization Host role service installed.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important in maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tsrpc.dll6.1.7600.16385123,39214-Jul-200901:41x64
Tsvmhasvc.dll6.1.7600.20761280,06421-Jul-201005:42x64
Vmhostgc.exe6.1.7600.2076130,20821-Jul-201004:00x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about Microsoft VDI, visit the following Microsoft website: For more information about how to install the RD Virtualization Host role service, visit the following Microsoft website:For more information about overview of RD Virtualization Host, visit the following Microsoft website:For more information about all Group Policy settings for Remote Desktop services in Windows Server 2008 R2, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_8285d66d41f7621a961df038016a1ede_31bf3856ad364e35_6.1.7600.20761_none_0b60ab3a3b8e2c1a.manifest
File versionNot applicable
File size724
Date (UTC)22-Jul-2010
Time (UTC)18:45
PlatformNot applicable
File nameAmd64_microsoft-windows-t..ces-tsv-vmhostagent_31bf3856ad364e35_6.1.7600.20761_none_ba0e39b095c24cb9.manifest
File versionNot applicable
File size46,302
Date (UTC)22-Jul-2010
Time (UTC)18:45
PlatformNot applicable
File namePackage_1_for_kb2096902~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,858
Date (UTC)22-Jul-2010
Time (UTC)18:45
PlatformNot applicable
File namePackage_for_kb2096902_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,472
Date (UTC)22-Jul-2010
Time (UTC)18:45
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2096902
Revision : 2
Created on : 9/25/2018
Published on : 9/25/2018
Exists online : False
Views : 314