Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ACC2000: Error Exporting to Existing Paradox or dBASE Table


View products that this article applies to.

Symptoms

In Microsoft Access, you cannot export a Paradox or dBASE table over the top of an existing, corrupted Paradox or dBASE database file. If you try, you receive the following error message:
Disk or network error
This error occurs with both dBASE and Paradox formats. Other database exports allow you to overwrite existing database files.

↑ Back to the top


Cause

Microsoft Access tries to open the file to verify its contents, instead of simply overwriting it.

↑ Back to the top


More information

Steps to Reproduce Behavior

  1. Create a new text file and save it as C:\Config.dbf. This simulates a corrupted dBASE database.
  2. Start Microsoft Access and open the sample database Northwind.mdb.
  3. Select the Customers table in the Database Window, and then click Export on the File menu.
  4. In the Export Table 'Customers' To dialog box, select drive C from the Save in box, type Config.dbf in the File name box, click dBASE III (*.dbf) in the Save as type box, and click Save.
  5. Click Yes when you get the message:
    The file Config.dbf already exists. Do you want to replace the existing file?
    Note that you receive the error message:
    Disk or network error

↑ Back to the top


Article Info
Article ID : 209540
Revision : 2
Created on : 1/1/0001
Published on : 1/1/0001
Exists online : False
Views : 266