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ACC2000: Cannot Save a Blank Record in a Table or Form


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This article was previously published under Q209148

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Symptoms

Novice: Requires knowledge of the user interface on single-user computers.

You cannot save a blank, new record in a table or form.

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Cause

Microsoft Access requires some form of data entry in the new record in order to create it.

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Resolution

To add a blank record to a table, press the SPACEBAR in any field in the table.

To add a blank record to a form, press the SPACEBAR in any field whose ControlSource property points to a field in the underlying record source. A SetValue or SendKeys macro action directed at the bound control will also add a blank record to a form.

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More information

When you are adding new records, Access does not recognize that a new record is being created until a field in the record has been "dirtied," or has received some input from an external source. That external source can be a keyboard entry (other than the TAB or ENTER keys), or it can be the result of a SendKeys or SetValue macro action. Note that default values for fields do not qualify as external input, and have no effect on triggering a new record in a table or form.

Steps to Reproduce Behavior

1.Change the ProductName field's AllowZeroLength property from No to Yes.
2.Save the table and then switch to Datasheet view.
3.On the Records menu, click Data Entry. Note that the insertion point is positioned at the first field in a blank record.
4.Press the TAB key to move through all the fields. Note that the record indicator does not increment, indicating that you are still on the same record and that the record has not been saved.
5.Press the TAB key to move to the ProductName field, and then press SPACEBAR.
6.Press the TAB key to move through the remaining fields until you return to the ProductName field. Note that the record indicator is increased by one.

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References

For more information about adding records, click Microsoft Access Help on the Help menu, type adding records to tables in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

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Keywords: KB209148, kbusage, kbprb

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Article Info
Article ID : 209148
Revision : 2
Created on : 6/28/2004
Published on : 6/28/2004
Exists online : False
Views : 251